aboutsummaryrefslogtreecommitdiffstats
path: root/community/ghc/0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch
diff options
context:
space:
mode:
authorRémi Lefèvre <rlefevre@dmy.fr>2019-12-10 08:57:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-12 16:31:59 +0000
commit42336c1358c0bc8186f48c20c6ae30f9ba63f1f3 (patch)
tree54f21d71fca8bd5d9a05a2f03aec4642c93caa3f /community/ghc/0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch
parentdb28db84a99ef663f3d06025a645c6c0d72a873a (diff)
downloadaports-42336c1358c0bc8186f48c20c6ae30f9ba63f1f3.tar.bz2
aports-42336c1358c0bc8186f48c20c6ae30f9ba63f1f3.tar.xz
community/ghc: fix testsuite on Alpine Linux
- Add `MAKEFLAGS= ` hack to work around failing `+PYTHON` - Add "stat too good" results for Alpine x64 - Increase tolerancy for two "stat not good enough" tests - Add a few more patches from mainline - Require gnu grep to fix T13340 & T7014 - Skip T2615 and T10458 (unresolved linking issues) Some tests should be investigated, particularly - T9630 (+22% memory allocation) - T10458: linking issue - T2615: linker script issue - T12600: broken pipe with grep .. | head -n 1 (replaced by grep -m 1) Hopefully we can get rid of the MAKEFLAGS hack once Hadrian is used.
Diffstat (limited to 'community/ghc/0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch')
-rw-r--r--community/ghc/0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/ghc/0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch b/community/ghc/0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch
new file mode 100644
index 0000000000..390f28e6d0
--- /dev/null
+++ b/community/ghc/0001-testsuite-T12600-avoid-broken-pipe-on-Alpine.patch
@@ -0,0 +1,27 @@
+From e5ebe63368c8b36310da609c625235647eae4340 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?R=C3=A9mi=20Lef=C3=A8vre?= <rlefevre@dmy.fr>
+Date: Tue, 10 Dec 2019 16:51:24 +0100
+Subject: testsuite: T12600 avoid broken pipe on Alpine
+
+Use grep -m 1 instead of | head -n 1 to avoid broken pipe.
+This should be investigated.
+---
+ testsuite/tests/simplCore/should_compile/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/testsuite/tests/simplCore/should_compile/Makefile b/testsuite/tests/simplCore/should_compile/Makefile
+index 5f077b2ebf..b38868bdaf 100644
+--- a/testsuite/tests/simplCore/should_compile/Makefile
++++ b/testsuite/tests/simplCore/should_compile/Makefile
+@@ -238,7 +238,7 @@ T11272:
+ # We expect to see a $wfoo worker that doesn't take any dictionaries.
+ .PHONY: T12600
+ T12600:
+- '$(TEST_HC)' $(TEST_HC_OPTS) -c -O -ddump-prep -dsuppress-all -dsuppress-uniques -dno-suppress-type-signatures -dppr-cols=200 T12600.hs | grep "wfoo" | head -n 1
++ '$(TEST_HC)' $(TEST_HC_OPTS) -c -O -ddump-prep -dsuppress-all -dsuppress-uniques -dno-suppress-type-signatures -dppr-cols=200 T12600.hs | grep -m 1 "wfoo"
+
+ # We don't expect to case match on any literal numbers other than
+ # 0 or 1. See T14140.hs for an explanation.
+--
+2.17.1
+