aboutsummaryrefslogtreecommitdiffstats
path: root/community/ghc/APKBUILD
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-08-09 15:43:10 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-12 16:31:59 +0000
commit981a3a5ed59c7564acaf78a59d89f9ae6da214c2 (patch)
treeb8b3abe26124d973da409cb14d74009f570af589 /community/ghc/APKBUILD
parent888086445f31ee79e91343d2dab7f78e3ef56011 (diff)
downloadaports-981a3a5ed59c7564acaf78a59d89f9ae6da214c2.tar.bz2
aports-981a3a5ed59c7564acaf78a59d89f9ae6da214c2.tar.xz
community/ghc: upgrade to 8.6.5
Diffstat (limited to 'community/ghc/APKBUILD')
-rw-r--r--community/ghc/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/community/ghc/APKBUILD b/community/ghc/APKBUILD
index 51b6eb4c8f..afa0977016 100644
--- a/community/ghc/APKBUILD
+++ b/community/ghc/APKBUILD
@@ -1,7 +1,8 @@
# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
pkgname=ghc
-pkgver=8.4.4
-pkgrel=1
+pkgver=8.6.5
+_llvmver=8
+pkgrel=0
# Normal non rc candidate
_urlprefix="$pkgver"
_pkgprefix="$pkgname-$pkgver"
@@ -12,18 +13,17 @@ pkgdesc="The Glasgow Haskell Compiler"
#pkgdate=20171108
#urlprefix="$pkgrcver-$pkgrc"
#pkgprefix="ghc-$pkgver.$pkgdate"
-url="http://haskell.org"
+url="https://haskell.org/"
arch="x86_64"
# Note ghc's license is basically BSD-3. If you'd like to know more visit:
# * https://www.haskell.org/ghc/license
# * https://ghc.haskell.org/trac/ghc/wiki/Licensing
license="BSD-3-Clause"
-# Note that ghc is sensitive to the version of llvm used,
-# hence the llvm5 dependency.
+# Note that ghc is sensitive to the version of llvm used.
#
# Ref: https://ghc.haskell.org/trac/ghc/wiki/Status/GHC-8.0.1
# https://ghc.haskell.org/trac/ghc/wiki/ImprovedLLVMBackend
-depends="gmp-dev perl gcc>=6.2.1 llvm5 libffi-dev"
+depends="gmp-dev perl gcc>=6.2.1 llvm$_llvmver libffi-dev"
# ghc is self-hosted, so we need ghc to build ghc. ghc-bootstrap is provided by
# this aport (see below).
makedepends_build="$pkgname-bootstrap
@@ -39,9 +39,9 @@ subpackages="$pkgname-doc $pkgname-dev"
install="$pkgname.post-install"
options="!strip" # we strip it manually in build()
source="https://downloads.haskell.org/~ghc/$_urlprefix/$_pkgprefix-src.tar.xz
- https://downloads.haskell.org/~ghc/$_urlprefix/$_pkgprefix-testsuite.tar.xz
- 0005-buildpath-abi-stability.patch
- "
+ https://downloads.haskell.org/~ghc/$_urlprefix/$_pkgprefix-testsuite.tar.xz
+ 0005-buildpath-abi-stability.patch
+ "
# We only need the bootstrap patch when bootstrapping a new arches ghc.
if [ "$CBUILD" != "$CTARGET" ]; then
@@ -183,6 +183,6 @@ dev() {
echo "$pfiles" | cpio -pamVd "$subpkgdir"
echo "$pfiles" | xargs rm -fr
}
-sha512sums="685e102eee8cf8b6a377afd7871998c8c368a5da288469367e3fb804aa6109e6f59be5945b8cd3d1e36c851190ea9a7f74c576528589589313d237b721d86da5 ghc-8.4.4-src.tar.xz
-9ee9382bb17689ec52528ea0c35d9d91f5a8aee37760cda7f312704f23dd731b72fcd012829c0817817ec2f307ab398d266e1b65078ac9cfec160df1d1b5ccb8 ghc-8.4.4-testsuite.tar.xz
+sha512sums="c08a7480200cb99e1ffbe4ce7669f552b1054054966f7e7efcbc5f98af8032e1249fa391c4fc4c7d62cc8e0be5d17fa05845177f3cea3dbcf86e6c92d40fc0f9 ghc-8.6.5-src.tar.xz
+980f3934bb18876cc80b80a0eb64a9ca1dfaa7f4d8b0761f5d733a6583053e38b231445388b992b26ec1ad5f569b6385dbe60f96381794f5577964979c253e16 ghc-8.6.5-testsuite.tar.xz
e1c2cef06d307eda4b35521204e95eb54ace5dbcd22de659e95356f884b4424d6304365e4ab45c5116192cba4c095e2e91114bc7cb73d7c7173a7035287d0854 0005-buildpath-abi-stability.patch"