aboutsummaryrefslogtreecommitdiffstats
path: root/community/ghc/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-12-05 09:14:14 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-12-05 10:28:47 +0000
commiteb371f0993fa9d20d84b0f5fc92f357792f5eaaf (patch)
tree5f98fdbeda5dd24b7513e3a33c12f4a1ebdbe65b /community/ghc/APKBUILD
parent0340f42fabee3853750b7b7f751b378bdf769db4 (diff)
downloadaports-eb371f0993fa9d20d84b0f5fc92f357792f5eaaf.tar.bz2
aports-eb371f0993fa9d20d84b0f5fc92f357792f5eaaf.tar.xz
community/ghc: keep static files in main package
don't split out -static because thseo files are needed to bootstrap ghc. We bootstrap ghc via provides ghc-bootstrap, and to avoid making things complicated we simply include the static files with ghc.
Diffstat (limited to 'community/ghc/APKBUILD')
-rw-r--r--community/ghc/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/ghc/APKBUILD b/community/ghc/APKBUILD
index 317c67ff05..51b6eb4c8f 100644
--- a/community/ghc/APKBUILD
+++ b/community/ghc/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
pkgname=ghc
pkgver=8.4.4
-pkgrel=0
+pkgrel=1
# Normal non rc candidate
_urlprefix="$pkgver"
_pkgprefix="$pkgname-$pkgver"
@@ -35,7 +35,7 @@ checkdepends="python3"
# Adding "ghc" to makedepends would not work, because abuild implicitly removes
# $pkgname and $subpackages from the abuild's dependencies.
provides="$pkgname-bootstrap=$pkgver-r$pkgrel"
-subpackages="$pkgname-static $pkgname-doc $pkgname-dev"
+subpackages="$pkgname-doc $pkgname-dev"
install="$pkgname.post-install"
options="!strip" # we strip it manually in build()
source="https://downloads.haskell.org/~ghc/$_urlprefix/$_pkgprefix-src.tar.xz