aboutsummaryrefslogtreecommitdiffstats
path: root/community/ghex
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:27:27 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:48 +0200
commitf59996b7863a2101fcc2ffb8cd553552fd2f1c38 (patch)
treed19cbecf9eff4f2a48ae5b7f87509bae0572c947 /community/ghex
parentdd9b58d3342bc9faab4b6a3aaf7dd2bbdfc33cc7 (diff)
downloadaports-f59996b7863a2101fcc2ffb8cd553552fd2f1c38.tar.bz2
aports-f59996b7863a2101fcc2ffb8cd553552fd2f1c38.tar.xz
community/ghex: move from testing
Diffstat (limited to 'community/ghex')
-rw-r--r--community/ghex/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/ghex/APKBUILD b/community/ghex/APKBUILD
new file mode 100644
index 0000000000..6f0c9d1b67
--- /dev/null
+++ b/community/ghex/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: August Klein <amatcoder@gmail.com>
+# Maintainer: August Klein <amatcoder@gmail.com>
+pkgname=ghex
+pkgver=3.18.4
+_pkgver=${pkgver%.*}
+pkgrel=0
+pkgdesc="A hex editor for GNOME"
+url="https://wiki.gnome.org/Apps/Ghex"
+arch="all"
+license="GPL-2.0-or-later"
+depends="dconf"
+makedepends="meson itstool gtk+3.0-dev glib-dev atk-dev"
+subpackages="$pkgname-dev $pkgname-lang $pkgname-doc"
+source="https://download.gnome.org/sources/ghex/$_pkgver/ghex-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ . output
+ ninja -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="6121a5986ee7d7f96bf7f401e155f8aa37f076af455bc68e43d1b5b02b63bc9aed3eba5209511d1b659eb4c9093ab5d9601c14a5e868d979e92a6d0ca0cf9ce2 ghex-3.18.4.tar.xz"