aboutsummaryrefslogtreecommitdiffstats
path: root/community/gifsicle
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-15 00:21:22 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-15 00:24:49 +0000
commit58f6ef8874c6bca08ebbbc823965ef27c18803ce (patch)
tree37f575106445b58c0eee3de6bd492f7c087c16d5 /community/gifsicle
parentc3f9e93560d419289cdf7742483d49ab3c5f5a18 (diff)
downloadaports-58f6ef8874c6bca08ebbbc823965ef27c18803ce.tar.bz2
aports-58f6ef8874c6bca08ebbbc823965ef27c18803ce.tar.xz
community/gifsicle: add check
Diffstat (limited to 'community/gifsicle')
-rw-r--r--community/gifsicle/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/gifsicle/APKBUILD b/community/gifsicle/APKBUILD
index 69dd66823f..806d42f8af 100644
--- a/community/gifsicle/APKBUILD
+++ b/community/gifsicle/APKBUILD
@@ -2,16 +2,17 @@
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=gifsicle
pkgver=1.91
-pkgrel=0
-pkgdesc="Command-line tool for making, editing, and getting information about GIF animations"
+pkgrel=1
+pkgdesc="Command-line tool for making, editing and getting information about GIF animations"
url="http://www.lcdf.org/gifsicle/"
arch="all"
license="GPL-2.0"
makedepends="libx11-dev libice-dev libsm-dev"
+checkdepends="perl"
subpackages="$pkgname-doc"
source="http://www.lcdf.org/gifsicle/gifsicle-$pkgver.tar.gz"
-builddir="$srcdir"/gifsicle-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -26,6 +27,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install