aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-lfs/makefile-extra_go_flags.patch
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-26 20:01:51 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-28 19:32:39 +0000
commitf3af9f768e97740c0f94529af53bf15bdff7ace2 (patch)
tree1fb263b9c48ca6bd33fce30644fad36bc368a1b7 /community/git-lfs/makefile-extra_go_flags.patch
parent8b7f9fa88e76aa1e5e331ff65641df3057b897ae (diff)
downloadaports-f3af9f768e97740c0f94529af53bf15bdff7ace2.tar.bz2
aports-f3af9f768e97740c0f94529af53bf15bdff7ace2.tar.xz
community/git-lfs: upgrade to 2.7.2
Closes GH-8139
Diffstat (limited to 'community/git-lfs/makefile-extra_go_flags.patch')
-rw-r--r--community/git-lfs/makefile-extra_go_flags.patch11
1 files changed, 8 insertions, 3 deletions
diff --git a/community/git-lfs/makefile-extra_go_flags.patch b/community/git-lfs/makefile-extra_go_flags.patch
index 16e2728906..c1437db65b 100644
--- a/community/git-lfs/makefile-extra_go_flags.patch
+++ b/community/git-lfs/makefile-extra_go_flags.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -128,7 +128,7 @@
+@@ -136,7 +136,7 @@
# It uses BUILD_MAIN as defined above to specify the entrypoint for building Git
# LFS.
BUILD = GOOS=$(1) GOARCH=$(2) \
@@ -8,12 +8,17 @@
+ $(GO) build $(EXTRA_GO_FLAGS) \
-ldflags="$(LD_FLAGS)" \
-gcflags="$(GC_FLAGS)" \
- -o ./bin/git-lfs$(3) $(BUILD_MAIN)
+ -asmflags="$(ASM_FLAGS)" \
+
--- a/t/Makefile
+++ b/t/Makefile
-@@ -37,4 +37,4 @@
+@@ -45,7 +45,7 @@
$(RM) $(TEST_CMDS)
../bin/%$X : cmd/%.go
- go build -o $@ $^
+ go build $(EXTRA_GO_FLAGS) -o $@ $^
+
+ ../bin/git-lfs-test-server-api$X : $(TEST_API_SRCS)
+- go build -o $@ $^
++ go build $(EXTRA_GO_FLAGS) -o $@ $^