aboutsummaryrefslogtreecommitdiffstats
path: root/community/git-lfs
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2019-05-26 20:01:51 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-28 19:32:39 +0000
commitf3af9f768e97740c0f94529af53bf15bdff7ace2 (patch)
tree1fb263b9c48ca6bd33fce30644fad36bc368a1b7 /community/git-lfs
parent8b7f9fa88e76aa1e5e331ff65641df3057b897ae (diff)
downloadaports-f3af9f768e97740c0f94529af53bf15bdff7ace2.tar.bz2
aports-f3af9f768e97740c0f94529af53bf15bdff7ace2.tar.xz
community/git-lfs: upgrade to 2.7.2
Closes GH-8139
Diffstat (limited to 'community/git-lfs')
-rw-r--r--community/git-lfs/APKBUILD38
-rw-r--r--community/git-lfs/fix-test-locks.patch2
-rw-r--r--community/git-lfs/makefile-extra_go_flags.patch11
3 files changed, 21 insertions, 30 deletions
diff --git a/community/git-lfs/APKBUILD b/community/git-lfs/APKBUILD
index 0eac0666a7..d5abb7f947 100644
--- a/community/git-lfs/APKBUILD
+++ b/community/git-lfs/APKBUILD
@@ -1,53 +1,36 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=git-lfs
-pkgver=2.5.1
-pkgrel=2
+pkgver=2.7.2
+pkgrel=0
pkgdesc="Git extension for versioning large files"
url="https://git-lfs.github.io/"
arch="all !x86"
license="MIT"
depends="git"
-checkdepends="bash coreutils git-daemon perl-utils"
makedepends="go ronn"
-subpackages="$pkgname-doc"
+checkdepends="bash coreutils git-daemon perl-utils"
install="$pkgname.post-install $pkgname.pre-deinstall"
+subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/git-lfs/$pkgname/archive/v$pkgver.tar.gz
fix-test-locks.patch
makefile-extra_go_flags.patch
"
-builddir="$srcdir/src/github.com/git-lfs/$pkgname"
-export GOPATH="$srcdir:$builddir"
# -tags netcgo - use system's DNS resolver by default. Go's built-in DNS
# resolver is buggy; it resolved localhost to totally wrong IP
# address on ARM builders and so caused test failures.
_goflags="-v -tags netcgo"
-prepare() {
- mkdir -p "${builddir%/*}"
- ln -s "$srcdir"/$pkgname-$pkgver "$builddir"
-
- default_prepare
-}
-
build() {
- cd "$builddir"
-
make \
EXTRA_GO_FLAGS="$_goflags" \
GIT_LFS_SHA="v$pkgver" \
VERSION="v$pkgver"
make man
-
- # Build test executables.
- local file; for file in t/cmd/*.go; do
- go build $_goflags -o bin/$(basename $file .go) $file
- done
}
check() {
- cd "$builddir"
make integration EXTRA_GO_FLAGS="$_goflags"
}
@@ -55,8 +38,6 @@ package() {
local docdir="$pkgdir/usr/share/doc/$pkgname"
local mandir="$pkgdir/usr/share/man"
- cd "$builddir"
-
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
mkdir -p "$mandir"/man1 "$mandir"/man5
@@ -68,6 +49,11 @@ package() {
rm -r "$docdir"/api/schemas
}
-sha512sums="86b277795ffaba47244f3467e58c1103804f526511c4b0c21566dc05a97eb5d48d0de36f944d906255a8652b9fd698dca4dd50f89d344703b3c6d87117f7fbc1 git-lfs-2.5.1.tar.gz
-8ef31d51ef730d6fbd61e1a839b808a00cacc004b84f3d274c19c47bd2f305bc8173c770573aeb9a454b5ac3ab60947cfaac9b414c51d3bcb857f99ac8de1c41 fix-test-locks.patch
-a66cbf518f15ca59f453ba28407f848aec1f752e3052007abd2196e288a0eef5618fdb1b8ffbad3aaff01bf84efef63d268f7208345e8e6d29c90a1748dd9ffd makefile-extra_go_flags.patch"
+cleanup_srcdir() {
+ go clean -modcache
+ default_cleanup_srcdir
+}
+
+sha512sums="cd71815eb418b7acaf077de4873ff49d332f71151c1212ca4fe3a2d0e079bad873894bb416488f272777153cc3422deecf17a849cd67f150b44eb094a09ae8be git-lfs-2.7.2.tar.gz
+a551d99af1770ea1d1cd9ccc0fcbed6d7d79fe81da6d3dff2462473ee531b95ca36c7759e48ece5bff1162db3d4ca05b17dd59d5f5e355aef84297c36cb4acf2 fix-test-locks.patch
+2d793da75b37324936407948fdb634ff4c510c4dd4d3575c2459b81a0a6eb8f2464f5066ae99e88d5bf69e357fd60354b9d9d53e062cb6ba709f5f3a39858466 makefile-extra_go_flags.patch"
diff --git a/community/git-lfs/fix-test-locks.patch b/community/git-lfs/fix-test-locks.patch
index 5e156c9dc9..fb4dd641df 100644
--- a/community/git-lfs/fix-test-locks.patch
+++ b/community/git-lfs/fix-test-locks.patch
@@ -2,7 +2,7 @@ This is probably a typo. I have no idea why it does not fail for upstream...
--- a/t/t-locks.sh
+++ b/t/t-locks.sh
-@@ -100,7 +100,7 @@
+@@ -129,7 +129,7 @@
for i in $(seq 1 5); do
git lfs lock --json "h_$i.dat" | tee lock.log
diff --git a/community/git-lfs/makefile-extra_go_flags.patch b/community/git-lfs/makefile-extra_go_flags.patch
index 16e2728906..c1437db65b 100644
--- a/community/git-lfs/makefile-extra_go_flags.patch
+++ b/community/git-lfs/makefile-extra_go_flags.patch
@@ -1,6 +1,6 @@
--- a/Makefile
+++ b/Makefile
-@@ -128,7 +128,7 @@
+@@ -136,7 +136,7 @@
# It uses BUILD_MAIN as defined above to specify the entrypoint for building Git
# LFS.
BUILD = GOOS=$(1) GOARCH=$(2) \
@@ -8,12 +8,17 @@
+ $(GO) build $(EXTRA_GO_FLAGS) \
-ldflags="$(LD_FLAGS)" \
-gcflags="$(GC_FLAGS)" \
- -o ./bin/git-lfs$(3) $(BUILD_MAIN)
+ -asmflags="$(ASM_FLAGS)" \
+
--- a/t/Makefile
+++ b/t/Makefile
-@@ -37,4 +37,4 @@
+@@ -45,7 +45,7 @@
$(RM) $(TEST_CMDS)
../bin/%$X : cmd/%.go
- go build -o $@ $^
+ go build $(EXTRA_GO_FLAGS) -o $@ $^
+
+ ../bin/git-lfs-test-server-api$X : $(TEST_API_SRCS)
+- go build -o $@ $^
++ go build $(EXTRA_GO_FLAGS) -o $@ $^