aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitea/allow-to-set-version.patch
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2017-03-10 00:30:23 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2017-03-10 00:30:23 +0100
commit23980ddbd76a735adb0f6f8f66b4a80d72df363a (patch)
tree9285b6a4fca77df9b3443fc83316f7d89cd6e616 /community/gitea/allow-to-set-version.patch
parent7852dbe781671abbe17bb633ffa2956fdd270716 (diff)
downloadaports-23980ddbd76a735adb0f6f8f66b4a80d72df363a.tar.bz2
aports-23980ddbd76a735adb0f6f8f66b4a80d72df363a.tar.xz
testing/gitea: move to community
Diffstat (limited to 'community/gitea/allow-to-set-version.patch')
-rw-r--r--community/gitea/allow-to-set-version.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/community/gitea/allow-to-set-version.patch b/community/gitea/allow-to-set-version.patch
new file mode 100644
index 0000000000..4be917c846
--- /dev/null
+++ b/community/gitea/allow-to-set-version.patch
@@ -0,0 +1,15 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -11,7 +11,11 @@
+ STYLESHEETS := $(wildcard public/less/index.less public/less/_*.less)
+ JAVASCRIPTS :=
+
+-LDFLAGS := -X "main.Version=$(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')" -X "main.Tags=$(TAGS)"
++ifeq ($(origin VERSION), undefined)
++ VERSION=$(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')
++endif
++
++LDFLAGS += -X "main.Version=$(VERSION)"
+
+ PACKAGES ?= $(filter-out code.gitea.io/gitea/integrations,$(shell go list ./... | grep -v /vendor/))
+ SOURCES ?= $(shell find . -name "*.go" -type f)