aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitea/allow-to-set-version.patch
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-11-07 04:18:42 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-07 14:56:27 +0000
commit9b5f1364c972192e9128c0a5f84b4ba88061e589 (patch)
tree642094ab7564867d6380b388969044bd8849f53f /community/gitea/allow-to-set-version.patch
parent1ae13d101f26d352c1c31e6ee226ecc5478d5bda (diff)
downloadaports-9b5f1364c972192e9128c0a5f84b4ba88061e589.tar.bz2
aports-9b5f1364c972192e9128c0a5f84b4ba88061e589.tar.xz
community/gitea: upgrade to 1.2.3
Diffstat (limited to 'community/gitea/allow-to-set-version.patch')
-rw-r--r--community/gitea/allow-to-set-version.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/gitea/allow-to-set-version.patch b/community/gitea/allow-to-set-version.patch
index 4be917c846..d5f609ebb3 100644
--- a/community/gitea/allow-to-set-version.patch
+++ b/community/gitea/allow-to-set-version.patch
@@ -1,8 +1,8 @@
---- ./Makefile.orig
-+++ ./Makefile
-@@ -11,7 +11,11 @@
- STYLESHEETS := $(wildcard public/less/index.less public/less/_*.less)
- JAVASCRIPTS :=
+--- a/Makefile
++++ b/Makefile
+@@ -23,7 +23,11 @@
+ GOFLAGS := -i -v
+ EXTRA_GOFLAGS ?=
-LDFLAGS := -X "main.Version=$(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')" -X "main.Tags=$(TAGS)"
+ifeq ($(origin VERSION), undefined)
@@ -11,5 +11,5 @@
+
+LDFLAGS += -X "main.Version=$(VERSION)"
- PACKAGES ?= $(filter-out code.gitea.io/gitea/integrations,$(shell go list ./... | grep -v /vendor/))
+ PACKAGES ?= $(filter-out code.gitea.io/gitea/integrations,$(shell $(GO) list ./... | grep -v /vendor/))
SOURCES ?= $(shell find . -name "*.go" -type f)