aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitea
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2018-08-12 10:48:14 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-08-12 10:48:31 +0000
commit0188ee1d98c0b00c99ff5ac5640bf28ada7c0327 (patch)
treeee5310f350dbf8cd12e1a29a2ea1fed2da40d359 /community/gitea
parentc5fa14d6882d7da466d2bbf76e3ffb5b8744b806 (diff)
downloadaports-0188ee1d98c0b00c99ff5ac5640bf28ada7c0327.tar.bz2
aports-0188ee1d98c0b00c99ff5ac5640bf28ada7c0327.tar.xz
community/gitea: upgrade to 1.5.0
Diffstat (limited to 'community/gitea')
-rw-r--r--community/gitea/APKBUILD8
-rw-r--r--community/gitea/allow-to-set-version.patch24
2 files changed, 14 insertions, 18 deletions
diff --git a/community/gitea/APKBUILD b/community/gitea/APKBUILD
index 7093c2b8c2..467db4b08c 100644
--- a/community/gitea/APKBUILD
+++ b/community/gitea/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=gitea
-pkgver=1.4.3
+pkgver=1.5.0
pkgrel=0
pkgdesc="A self-hosted Git service written in Go"
url="https://gitea.io"
@@ -31,7 +31,7 @@ build() {
cd "$builddir"
export GOPATH="$srcdir"
export TAGS="tidb sqlite"
- export VERSION="$pkgver"
+ export GITEA_VERSION="$pkgver"
unset LDFLAGS
make build
}
@@ -68,7 +68,7 @@ check() {
"$builddir"/$pkgname help > /dev/null
}
-sha512sums="24498b418b9ddb14da5568a206e1fa0831c5789e0b64207f413c3b86e2a855052f7af80d3cb80549eaae6944e22af271c00f6308c66487c3be0dccf55a17976a gitea-1.4.3.tar.gz
+sha512sums="06cbcadc138496abf500b8d219d0770c5f6b8af419f9c3733596ee7e20cb50235815433979b2b1daa0a6117e6eb84de9678667236549e018079c49b793f22d68 gitea-1.5.0.tar.gz
a7c70a144dc0582d6230e59ff717023fddcac001a6a9c895b46a0df1fbd9639453b2f5027d47dad21f442869c145dbc801eda61b6c50a2dd8103f562b8569009 gitea.initd
27a202006d6e8d4146659f6356eaa99437f9f596dd369e9430d64b859bc6a1ad16091eef09232aa385fe1bf8ca94bbdf31b94975068220ad10338cded384f726 gitea.ini
-a49e6d820e2ca4c8d583b31a8eb02d8bf3cb7a96ac4f82196fbeb4de0ed22e8e1f64b0f2a6edabed94a07762df0788a2a29dbd58db5213ea6c83c9d0bd7ba24d allow-to-set-version.patch"
+05272f3733dffeb75881579ff6553d32515e4de32113ff9395e521e93946a45101d04d4e435d7d8e7bfe49a512e5e4ac300576d2e79d7bcf314fc0ce526a07f9 allow-to-set-version.patch"
diff --git a/community/gitea/allow-to-set-version.patch b/community/gitea/allow-to-set-version.patch
index d5f609ebb3..5f9321dc20 100644
--- a/community/gitea/allow-to-set-version.patch
+++ b/community/gitea/allow-to-set-version.patch
@@ -1,15 +1,11 @@
---- a/Makefile
-+++ b/Makefile
-@@ -23,7 +23,11 @@
- GOFLAGS := -i -v
- EXTRA_GOFLAGS ?=
+--- ./Makefile.orig
++++ ./Makefile
+@@ -30,7 +30,7 @@
+ else
+ VERSION ?= master
+ endif
+- GITEA_VERSION := $(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')
++ GITEA_VERSION ?= $(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')
+ endif
--LDFLAGS := -X "main.Version=$(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')" -X "main.Tags=$(TAGS)"
-+ifeq ($(origin VERSION), undefined)
-+ VERSION=$(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')
-+endif
-+
-+LDFLAGS += -X "main.Version=$(VERSION)"
-
- PACKAGES ?= $(filter-out code.gitea.io/gitea/integrations,$(shell $(GO) list ./... | grep -v /vendor/))
- SOURCES ?= $(shell find . -name "*.go" -type f)
+ LDFLAGS := -X "main.Version=$(GITEA_VERSION)" -X "main.Tags=$(TAGS)"