aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitea
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-11-07 04:18:42 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-07 14:56:27 +0000
commit9b5f1364c972192e9128c0a5f84b4ba88061e589 (patch)
tree642094ab7564867d6380b388969044bd8849f53f /community/gitea
parent1ae13d101f26d352c1c31e6ee226ecc5478d5bda (diff)
downloadaports-9b5f1364c972192e9128c0a5f84b4ba88061e589.tar.bz2
aports-9b5f1364c972192e9128c0a5f84b4ba88061e589.tar.xz
community/gitea: upgrade to 1.2.3
Diffstat (limited to 'community/gitea')
-rw-r--r--community/gitea/APKBUILD6
-rw-r--r--community/gitea/allow-to-set-version.patch12
2 files changed, 9 insertions, 9 deletions
diff --git a/community/gitea/APKBUILD b/community/gitea/APKBUILD
index 9bc07abe3d..c5755f765b 100644
--- a/community/gitea/APKBUILD
+++ b/community/gitea/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
# Maintainer: Carlo Landmeter <clandmeter@gmail.com>
pkgname=gitea
-pkgver=1.2.2
+pkgver=1.2.3
pkgrel=0
pkgdesc="A self-hosted Git service written in Go"
url="http://gitea.io/"
@@ -67,7 +67,7 @@ check() {
"$builddir"/$pkgname help > /dev/null
}
-sha512sums="a0efca25a13d157c5d56308f6febdc7b70e5438a74f68de76a44444dac1f38cec3e3c4484c7f69c3773ffff0d6790ab2da29e1d9198d65a84c1802c9848fb2a5 gitea-1.2.2.tar.gz
+sha512sums="b519bb2fae20da75444a9cb971ab1db0aed04261c6522464feb2e0bad28bc5b8fff3ce8a85f8d26e9cfe79b41c29e540b3ff0aa0c3e99ce90e9e9a1ec26a165e gitea-1.2.3.tar.gz
a7c70a144dc0582d6230e59ff717023fddcac001a6a9c895b46a0df1fbd9639453b2f5027d47dad21f442869c145dbc801eda61b6c50a2dd8103f562b8569009 gitea.initd
27a202006d6e8d4146659f6356eaa99437f9f596dd369e9430d64b859bc6a1ad16091eef09232aa385fe1bf8ca94bbdf31b94975068220ad10338cded384f726 gitea.ini
-e38a701faed6749cbb897536d9ec7e723dc258c01b43daea7e19f3bd56dda4d69cd3be2b0813c24bef902f0b82c734120e36276b4e72899d2d2b3be54dc4574e allow-to-set-version.patch"
+a49e6d820e2ca4c8d583b31a8eb02d8bf3cb7a96ac4f82196fbeb4de0ed22e8e1f64b0f2a6edabed94a07762df0788a2a29dbd58db5213ea6c83c9d0bd7ba24d allow-to-set-version.patch"
diff --git a/community/gitea/allow-to-set-version.patch b/community/gitea/allow-to-set-version.patch
index 4be917c846..d5f609ebb3 100644
--- a/community/gitea/allow-to-set-version.patch
+++ b/community/gitea/allow-to-set-version.patch
@@ -1,8 +1,8 @@
---- ./Makefile.orig
-+++ ./Makefile
-@@ -11,7 +11,11 @@
- STYLESHEETS := $(wildcard public/less/index.less public/less/_*.less)
- JAVASCRIPTS :=
+--- a/Makefile
++++ b/Makefile
+@@ -23,7 +23,11 @@
+ GOFLAGS := -i -v
+ EXTRA_GOFLAGS ?=
-LDFLAGS := -X "main.Version=$(shell git describe --tags --always | sed 's/-/+/' | sed 's/^v//')" -X "main.Tags=$(TAGS)"
+ifeq ($(origin VERSION), undefined)
@@ -11,5 +11,5 @@
+
+LDFLAGS += -X "main.Version=$(VERSION)"
- PACKAGES ?= $(filter-out code.gitea.io/gitea/integrations,$(shell go list ./... | grep -v /vendor/))
+ PACKAGES ?= $(filter-out code.gitea.io/gitea/integrations,$(shell $(GO) list ./... | grep -v /vendor/))
SOURCES ?= $(shell find . -name "*.go" -type f)