aboutsummaryrefslogtreecommitdiffstats
path: root/community/gitg
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:27:22 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:48 +0200
commitdd9b58d3342bc9faab4b6a3aaf7dd2bbdfc33cc7 (patch)
treebd3fa68825ec310008f58d637e46555c3b2d0b49 /community/gitg
parent4695f72ad970149e40dc3c324384b333ed88d353 (diff)
downloadaports-dd9b58d3342bc9faab4b6a3aaf7dd2bbdfc33cc7.tar.bz2
aports-dd9b58d3342bc9faab4b6a3aaf7dd2bbdfc33cc7.tar.xz
community/gitg: move from testing
Diffstat (limited to 'community/gitg')
-rw-r--r--community/gitg/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/gitg/APKBUILD b/community/gitg/APKBUILD
new file mode 100644
index 0000000000..546d844d1f
--- /dev/null
+++ b/community/gitg/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gitg
+pkgver=3.32.1
+pkgrel=0
+pkgdesc="gitg is the GNOME GUI client to view git repositories"
+url="https://wiki.gnome.org/Apps/Gitg"
+arch="all"
+license="GPL-2.0-or-later"
+depends="gsettings-desktop-schemas"
+makedepends="meson libsoup-dev libgee-dev glib-dev gobject-introspection-dev vala
+ gsettings-desktop-schemas-dev libpeas-dev libgit2-glib-dev gtk+3.0-dev libsecret-dev
+ libxml2-dev libdazzle-dev gtkspell3-dev gtksourceview-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/gitg/${pkgver%.*}/gitg-${pkgver}.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="243e630b3e5bb1919dc307e6b3fed1b1b0e3884d2a2507e4526b4af61e86f1cd7004a3dbb96001ffb0280cefe7cdb9b109c39996718913c7410224830c0145a4 gitg-3.32.1.tar.xz"