aboutsummaryrefslogtreecommitdiffstats
path: root/community/glade
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-08-13 10:53:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-08-13 11:21:17 +0000
commit19741d784761bf6720ad203b56858b18a05e659d (patch)
tree8c2ce1ebfc4135422833eca5fc050c53e01786c7 /community/glade
parent0c75836c4e844b499cea837943dc3e3270101435 (diff)
downloadaports-19741d784761bf6720ad203b56858b18a05e659d.tar.bz2
aports-19741d784761bf6720ad203b56858b18a05e659d.tar.xz
community/glade: move from main
Diffstat (limited to 'community/glade')
-rw-r--r--community/glade/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/glade/APKBUILD b/community/glade/APKBUILD
new file mode 100644
index 0000000000..c3dc081cb4
--- /dev/null
+++ b/community/glade/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=glade
+pkgver=3.22.1
+pkgrel=0
+pkgdesc="User Interface Designer for GTK+ and GNOME"
+url="https://glade.gnome.org/"
+arch="all"
+license="GPL"
+makedepends="gtk+3.0-dev libxml2-dev itstool gtk-doc paxmark"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/glade/${pkgver%.*}/glade-$pkgver.tar.xz"
+
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --enable-compile-warnings=no \
+ --enable-gtk-doc
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" DATADIRNAME=share install
+ paxmark -r "$pkgdir"/usr/bin/glade
+}
+
+sha512sums="e1bdc49b89bc5010c0abf6357dbae05c921182655b2ee5a4b161af6adfd596cfbcd495c9851ba956abbf3d6156616a6c0e94640cd72cee11551ca388674ac908 glade-3.22.1.tar.xz"