aboutsummaryrefslogtreecommitdiffstats
path: root/community/glade
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-06 13:29:27 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 17:48:51 +0000
commit036b2a010d918df3e2a17ed2b3cedf12f6891e3f (patch)
tree711cbd98ea10e1d9b4194008bc9be4757123462a /community/glade
parent368038c3871f94ea2b03227cb1213a6ec924abf0 (diff)
downloadaports-036b2a010d918df3e2a17ed2b3cedf12f6891e3f.tar.bz2
aports-036b2a010d918df3e2a17ed2b3cedf12f6891e3f.tar.xz
community/glade: enable WebKit&Python catalog, GIR and GladeUI
* Adopt maintainership
Diffstat (limited to 'community/glade')
-rw-r--r--community/glade/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/glade/APKBUILD b/community/glade/APKBUILD
index 9942a2523f..2c23daa16d 100644
--- a/community/glade/APKBUILD
+++ b/community/glade/APKBUILD
@@ -1,19 +1,20 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=glade
pkgver=3.22.1
-pkgrel=0
+pkgrel=1
pkgdesc="User Interface Designer for GTK+ and GNOME"
url="https://glade.gnome.org/"
arch="all"
-license="GPL"
-makedepends="gtk+3.0-dev libxml2-dev itstool gtk-doc paxmark intltool"
+license="GPL-2.0-or-later"
+makedepends="gtk+3.0-dev libxml2-dev itstool gtk-doc paxmark intltool
+ webkit2gtk-dev py-gobject3-dev gobject-introspection-dev"
+checkdepends="xvfb-run ibus adwaita-icon-theme"
+options="!check" # If adwaita-icon-theme wasn't installed e before we'd have to updathe the icon cache
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
source="https://download.gnome.org/sources/glade/${pkgver%.*}/glade-$pkgver.tar.xz"
-builddir="$srcdir/$pkgname-$pkgver"
-
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -22,12 +23,16 @@ build() {
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--enable-compile-warnings=no \
- --enable-gtk-doc
+ --enable-gtk-doc \
+ --enable-gladeui
make
}
+check() {
+ xvfb-run make check
+}
+
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" DATADIRNAME=share install
paxmark -r "$pkgdir"/usr/bin/glade
}