aboutsummaryrefslogtreecommitdiffstats
path: root/community/glances/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-25 21:46:27 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-27 15:13:37 +0000
commitf35a349c11f5d94bcecf5d3b8c8a3bcf22ec3488 (patch)
tree0d12018331094abd0e64a5b3b5122e11edb5fe66 /community/glances/APKBUILD
parent5e44ecc853ea2a9c2c70743a3a7886f4324db85f (diff)
downloadaports-f35a349c11f5d94bcecf5d3b8c8a3bcf22ec3488.tar.bz2
aports-f35a349c11f5d94bcecf5d3b8c8a3bcf22ec3488.tar.xz
community/glances: modernize
Diffstat (limited to 'community/glances/APKBUILD')
-rw-r--r--community/glances/APKBUILD7
1 files changed, 1 insertions, 6 deletions
diff --git a/community/glances/APKBUILD b/community/glances/APKBUILD
index b8a6673700..bbb0a5e49f 100644
--- a/community/glances/APKBUILD
+++ b/community/glances/APKBUILD
@@ -9,25 +9,20 @@ pkgdesc="A CLI curses based monitoring tool"
url="http://nicolargo.github.com/glances/"
arch="noarch"
license="LGPL-3.0-or-later"
-depends="py3-psutil py3-bottle py3-snmp py3-batinfo docker-py py3-setuptools"
-makedepends="python3-dev py3-setuptools"
+depends="py3-psutil py3-bottle py3-snmp py3-batinfo docker-py"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/nicolargo/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
options="!check" # tests fail on builder infra due to env. limitations
build() {
- cd "$builddir"
python3 setup.py build
}
check() {
- cd "$builddir"
python3 unitest.py
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
# Remove images and HTML doc depending on those