aboutsummaryrefslogtreecommitdiffstats
path: root/community/glm
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-03-26 14:03:22 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-03-26 15:23:25 +0000
commit3711c9320d155487634c081b84af81e3af87ea26 (patch)
treea4174880b64678ecebee9ee43d5c8b8514443984 /community/glm
parent55633105c0523de99036377b04be34729a56673d (diff)
downloadaports-3711c9320d155487634c081b84af81e3af87ea26.tar.bz2
aports-3711c9320d155487634c081b84af81e3af87ea26.tar.xz
community/glm: upgrade to 0.9.9.7
- Changed url to https - Switched to cmake -B flag - Removed unused cmake var CMAKE_INSTALL_LIBDIR
Diffstat (limited to 'community/glm')
-rw-r--r--community/glm/APKBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/community/glm/APKBUILD b/community/glm/APKBUILD
index 83b326298d..6210993e18 100644
--- a/community/glm/APKBUILD
+++ b/community/glm/APKBUILD
@@ -1,9 +1,9 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=glm
-pkgver=0.9.9.6
-pkgrel=1
+pkgver=0.9.9.7
+pkgrel=0
pkgdesc="C++ mathematics library for graphics programming"
-url="http://glm.g-truc.net/"
+url="https://glm.g-truc.net/"
arch="noarch"
license="MIT"
makedepends="cmake"
@@ -12,24 +12,18 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/g-truc/glm/archive/$pkgver.t
fix-endian-test.patch
glm.pc
"
-builddir="$srcdir/$pkgname-$pkgver"
patch_args="--binary -p1"
build() {
- cd "$builddir"
- mkdir build
- cd build
- cmake .. \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -B build \
-DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DGLM_TEST_ENABLE=TRUE
- make
+ make -C build
}
check() {
- cd "$builddir"/build
- make test
+ make -C build test
}
package() {
@@ -38,9 +32,9 @@ package() {
mkdir -p "$pkgdir"/usr/share/doc
cp -r doc "$pkgdir"/usr/share/doc/glm
mkdir -p "$pkgdir"/usr/lib/pkgconfig
- cp ../glm.pc "$pkgdir"/usr/lib/pkgconfig/
+ cp "$srcdir"/glm.pc "$pkgdir"/usr/lib/pkgconfig/
}
-sha512sums="1bc8fc1da21e19f95d4a24259993c7932db328fdd2d0db68dbf60c07f372e19003a8df094fb4e153bb7f50df584c17cf0a540d3d3c38b7a287f3b55314ec2d70 glm-0.9.9.6.tar.gz
+sha512sums="9c557788d6382777317c94f8b30bc3df7e533877705514fa5d384f97b076d6bc750e841acbecdec8113e21af07bd8850159f5f1e079aaa2cde25540b480f983b glm-0.9.9.7.tar.gz
93e02285b7530bb5fdad71905a55150e64cda3d036f43fca166eddb2e8d2f2d03025543c96dfd44234a37f860ea0682be2c683a66c9d4ef33f5bc269c95bbdfa fix-endian-test.patch
185a9eae06b4bd291c72351239a969e37b83feb1b2de64c397f657370aff81241bf489f0109c74d50cd7106389c2740b0f620f39cdd3604dc51ed9b5046442af glm.pc"