aboutsummaryrefslogtreecommitdiffstats
path: root/community/glslang
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 17:21:54 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-28 15:18:09 +0000
commit004d29a8fb81b65c79bd726b0f2e6dd48f41338d (patch)
tree1f0c8f6cc9ac22fe1c750ce3de8c438c324aa669 /community/glslang
parent1d7306ada2ff07632e74aa65fcf25849e082d2d9 (diff)
downloadaports-004d29a8fb81b65c79bd726b0f2e6dd48f41338d.tar.bz2
aports-004d29a8fb81b65c79bd726b0f2e6dd48f41338d.tar.xz
community/glslang: move from testing
Diffstat (limited to 'community/glslang')
-rw-r--r--community/glslang/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/glslang/APKBUILD b/community/glslang/APKBUILD
new file mode 100644
index 0000000000..a37f023aed
--- /dev/null
+++ b/community/glslang/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=glslang
+pkgver=7.11.3214
+pkgrel=0
+pkgdesc="Khronos reference front-end for GLSL, ESSL, and sample SPIR-V generator"
+options="!check" # Requires git checkout of gmock
+url="https://github.com/KhronosGroup/glslang"
+arch="all"
+license="BSD-3-Clause"
+depends_dev="$pkgname"
+makedepends="cmake python3 bison"
+subpackages="$pkgname-static $pkgname-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/KhronosGroup/glslang/archive/${pkgver}.tar.gz"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ -DBUILD_SHARED_LIBS=ON \
+ ${CMAKE_CROSSOPTS} .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="5e7f8c063b30fc5edf65898b2371f4128aead05008865d065de9d3a94354de787035067ec908651c7e88bf294251d1410929d2b1c19e03d9b51476ea8a7eae96 glslang-7.11.3214.tar.gz"