aboutsummaryrefslogtreecommitdiffstats
path: root/community/gmime26
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:25:21 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:47 +0200
commitceb34137fe9c92b904d5fd280f288d177e74143a (patch)
treead059285b4ce29e26228f5b07faee3f5ef6faeb1 /community/gmime26
parentffb488e5473089489966e8f9414e16eb7d69ab81 (diff)
downloadaports-ceb34137fe9c92b904d5fd280f288d177e74143a.tar.bz2
aports-ceb34137fe9c92b904d5fd280f288d177e74143a.tar.xz
community/gmime26: move from testing
Diffstat (limited to 'community/gmime26')
-rw-r--r--community/gmime26/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/gmime26/APKBUILD b/community/gmime26/APKBUILD
new file mode 100644
index 0000000000..e3f461bed5
--- /dev/null
+++ b/community/gmime26/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gmime26
+pkgver=2.6.23
+pkgrel=0
+pkgdesc="A C/C++ MIME creation and parser library with support for S/MIME, PGP"
+url="https://developer.gnome.org/gmime/"
+arch="all"
+license="LGPL-2.1-only"
+depends_dev="gpgme-dev"
+makedepends="$depends_dev glib-dev intltool vala gobject-introspection-dev"
+options="!check" # iconv doesn't work on musl
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/gmime/${pkgver%.*}/gmime-$pkgver.tar.xz"
+
+builddir="$srcdir/gmime-$pkgver"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-vala \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="2ff6718b7a555cd5b34848399f29c7d0aa5a15e1f3cb46e9258c499e874191ee00f41b737386805d3000bad34367d174a25c45d38ba90cba7902400e733afa14 gmime-2.6.23.tar.xz"