aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-autoar/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-22 23:51:17 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-22 23:52:42 +0200
commitd33cdd519c268c5fd3e859b6f818b2530a4d05ec (patch)
treea36cbb547d3fa7d70469cb9abb4dab6373cf8256 /community/gnome-autoar/APKBUILD
parent34d8cccf68981a90c0fa0e4111b0c5825781b7f7 (diff)
downloadaports-d33cdd519c268c5fd3e859b6f818b2530a4d05ec.tar.bz2
aports-d33cdd519c268c5fd3e859b6f818b2530a4d05ec.tar.xz
community/gnome-autoar: move from testing
Diffstat (limited to 'community/gnome-autoar/APKBUILD')
-rw-r--r--community/gnome-autoar/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/gnome-autoar/APKBUILD b/community/gnome-autoar/APKBUILD
new file mode 100644
index 0000000000..0235b946b4
--- /dev/null
+++ b/community/gnome-autoar/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer:
+pkgname=gnome-autoar
+pkgver=0.2.3
+pkgrel=0
+pkgdesc="GNOME archive extraction library"
+url="https://www.gnome.org/"
+arch="all !s390x"
+license="GPL"
+depends=""
+depends_dev="gnome-desktop-dev libarchive-dev"
+makedepends="$depends_dev vala"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://download.gnome.org/sources/gnome-autoar/${pkgver%.*}/gnome-autoar-$pkgver.tar.xz"
+builddir="$srcdir/gnome-autoar-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+sha512sums="f87299817c52e7862a6c1cc950b1c362db8e7465e008d988e70245a203c728a9179400aac8601c399abe361e5a1ac4558b1190641ad3afa7224f883546fae7bc gnome-autoar-0.2.3.tar.xz"