aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-backgrounds
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:12:21 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:47 +0200
commit5e412f51c3b730413c62bf80840e5e0ec6ac5135 (patch)
treed08922b69f27b3c9bc3e7bdba035d21ae1a878dc /community/gnome-backgrounds
parent78658881c46e4c182033718536acee582c6cfc8e (diff)
downloadaports-5e412f51c3b730413c62bf80840e5e0ec6ac5135.tar.bz2
aports-5e412f51c3b730413c62bf80840e5e0ec6ac5135.tar.xz
community/gnome-backgrounds: move from testing
Diffstat (limited to 'community/gnome-backgrounds')
-rw-r--r--community/gnome-backgrounds/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/gnome-backgrounds/APKBUILD b/community/gnome-backgrounds/APKBUILD
new file mode 100644
index 0000000000..16e04aaaef
--- /dev/null
+++ b/community/gnome-backgrounds/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnome-backgrounds
+pkgver=3.34.0
+pkgrel=0
+pkgdesc="Default wallpaper set for GNOME"
+url="https://gitlab.gnome.org/GNOME/gnome-backgrounds"
+arch="noarch"
+license="GPL-2.0-or-later CC-BY-2.0 CC-BY-SA-2.0 CC-BY-SA-3.0"
+makedepends="meson gettext-dev"
+options="!check" # no tests for wallpapers
+subpackages="$pkgname-lang"
+source="https://download.gnome.org/sources/gnome-backgrounds/${pkgver%.*}/gnome-backgrounds-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --buildtype=release \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ output .
+ ninja -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="bea6df85611a845c1013091dfccfd1d1fc697781a74348d936c15f8cec1ace765c37e6f57fed403cc2c6a91a18e522c8cc3db74b2c2327cd3ed71371075a9834 gnome-backgrounds-3.34.0.tar.xz"