aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-bluetooth
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-05-04 18:56:49 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-04 17:23:46 +0000
commit4c2ab1fd564f84fddd312162cb95bbe28dff02b0 (patch)
treebc5bc32ec10c69db3eaf1e0a20ddcf8e4387a1c1 /community/gnome-bluetooth
parentd60eb167560ee1f4dd4c83b16523e34ef08051bd (diff)
downloadaports-4c2ab1fd564f84fddd312162cb95bbe28dff02b0.tar.bz2
aports-4c2ab1fd564f84fddd312162cb95bbe28dff02b0.tar.xz
community/gnome-bluetooth: upgrade to 3.32.1
Also fix the homepage&license, streamline the usage of meson/ninja and adopt the package
Diffstat (limited to 'community/gnome-bluetooth')
-rw-r--r--community/gnome-bluetooth/APKBUILD35
-rw-r--r--community/gnome-bluetooth/libnotify-0.7.patch11
-rw-r--r--community/gnome-bluetooth/nogeoclue.patch138
3 files changed, 13 insertions, 171 deletions
diff --git a/community/gnome-bluetooth/APKBUILD b/community/gnome-bluetooth/APKBUILD
index 810ddec141..41ec1e7c4b 100644
--- a/community/gnome-bluetooth/APKBUILD
+++ b/community/gnome-bluetooth/APKBUILD
@@ -1,44 +1,35 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-bluetooth
-pkgver=3.28.2
+pkgver=3.32.1
pkgrel=0
pkgdesc="The GNOME Bluetooth Subsystem"
-url="http://live.gnome.org/GnomeBluetooth"
+url="https://wiki.gnome.org/Projects/GnomeBluetooth"
arch="all"
-license="GPL LGPL"
+license="GPL-2.0-or-later LGPL-2.1-or-later"
depends="hicolor-icon-theme bluez>=5"
-makedepends="intltool gobject-introspection-dev libunique-dev
- libnotify-dev libxi-dev libxslt gnome-doc-utils
- dbus-glib-dev gtk+3.0-dev itstool eudev-dev libcanberra-dev
- meson"
+makedepends="dconf-dev gobject-introspection-dev libnotify-dev libxi-dev
+ dbus-glib-dev gtk+3.0-dev eudev-dev libcanberra-dev meson"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-libs"
source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
61-gnome-bluetooth-rfkill.rules"
builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- default_prepare
- cd "$builddir"
- mkdir -p build
-}
-
build() {
- cd "$builddir"/build
meson \
--prefix=/usr \
--buildtype=release \
- --sysconfdir=/etc ..
- ninja
+ --sysconfdir=/etc \
+ output .
+ ninja -C output
}
check() {
- cd "$builddir"/build
- ninja test
+ ninja -C output test
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" ninja -C output install
install -m644 -D "$srcdir/61-gnome-bluetooth-rfkill.rules" \
"$pkgdir/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules"
}
@@ -50,5 +41,5 @@ libs() {
mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
}
-sha512sums="03f66f8c5c195b10cf2c13dc93191b9f2f79adae099ddb8037ef1277731f37b8f0a42b603e8aacbe2fb108be6abf7a77a823d86d5fac62a42a53e3498d53d87e gnome-bluetooth-3.28.2.tar.xz
+sha512sums="75444a639385cda5ac936cd70e1cf9a5a6d156b717afef1d59fd62e638418790106c8f060c7c62b7f171db99b5d669d40447598a0f7c8897be810a9b1d3c9c28 gnome-bluetooth-3.32.1.tar.xz
80b7fd0bc3e0f82c8d2d609ffed634200e63f61d9a134445df8e8511756b7fb423d338a1d12e42b91c57243097beaa3d4662856ec0507fb19a29b6de7ee9e4de 61-gnome-bluetooth-rfkill.rules"
diff --git a/community/gnome-bluetooth/libnotify-0.7.patch b/community/gnome-bluetooth/libnotify-0.7.patch
deleted file mode 100644
index 5265e460ef..0000000000
--- a/community/gnome-bluetooth/libnotify-0.7.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./applet/notify.c.orig
-+++ ./applet/notify.c
-@@ -71,7 +71,7 @@
- notify_notification_close(notify, NULL);
- }
-
-- notify = notify_notification_new(summary, message, icon_name, NULL);
-+ notify = notify_notification_new(summary, message, icon_name);
-
- notify_notification_set_timeout(notify, timeout);
-
diff --git a/community/gnome-bluetooth/nogeoclue.patch b/community/gnome-bluetooth/nogeoclue.patch
deleted file mode 100644
index 2892bee0ca..0000000000
--- a/community/gnome-bluetooth/nogeoclue.patch
+++ /dev/null
@@ -1,138 +0,0 @@
---- gnome-bluetooth-2.32.0.orig/configure
-+++ gnome-bluetooth-2.32.0/configure
-@@ -638,8 +638,6 @@
- MOBLIN_CFLAGS
- PLUGINS_LIBS
- PLUGINS_CFLAGS
--GEOCLUE_LIBS
--GEOCLUE_CFLAGS
- COMMON_LIBS
- COMMON_CFLAGS
- LIBGNOMEBT_LIBS
-@@ -899,8 +897,6 @@
- LIBGNOMEBT_LIBS
- COMMON_CFLAGS
- COMMON_LIBS
--GEOCLUE_CFLAGS
--GEOCLUE_LIBS
- PLUGINS_CFLAGS
- PLUGINS_LIBS
- MOBLIN_CFLAGS
-@@ -13662,106 +13658,6 @@
-
- fi
-
--
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GEOCLUE" >&5
--$as_echo_n "checking for GEOCLUE... " >&6; }
--
--if test -n "$GEOCLUE_CFLAGS"; then
-- pkg_cv_GEOCLUE_CFLAGS="$GEOCLUE_CFLAGS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gconf-2.0
-- dbus-glib-1\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "gconf-2.0
-- dbus-glib-1") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_GEOCLUE_CFLAGS=`$PKG_CONFIG --cflags "gconf-2.0
-- dbus-glib-1" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--if test -n "$GEOCLUE_LIBS"; then
-- pkg_cv_GEOCLUE_LIBS="$GEOCLUE_LIBS"
-- elif test -n "$PKG_CONFIG"; then
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gconf-2.0
-- dbus-glib-1\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "gconf-2.0
-- dbus-glib-1") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_GEOCLUE_LIBS=`$PKG_CONFIG --libs "gconf-2.0
-- dbus-glib-1" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- GEOCLUE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "gconf-2.0
-- dbus-glib-1" 2>&1`
-- else
-- GEOCLUE_PKG_ERRORS=`$PKG_CONFIG --print-errors "gconf-2.0
-- dbus-glib-1" 2>&1`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$GEOCLUE_PKG_ERRORS" >&5
--
-- as_fn_error $? "Package requirements (gconf-2.0
-- dbus-glib-1) were not met:
--
--$GEOCLUE_PKG_ERRORS
--
--Consider adjusting the PKG_CONFIG_PATH environment variable if you
--installed software in a non-standard prefix.
--
--Alternatively, you may set the environment variables GEOCLUE_CFLAGS
--and GEOCLUE_LIBS to avoid the need to call pkg-config.
--See the pkg-config man page for more details." "$LINENO" 5
--
--elif test $pkg_failed = untried; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
--$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
--as_fn_error $? "The pkg-config script could not be found or is too old. Make sure it
--is in your PATH or set the PKG_CONFIG environment variable to the full
--path to pkg-config.
--
--Alternatively, you may set the environment variables GEOCLUE_CFLAGS
--and GEOCLUE_LIBS to avoid the need to call pkg-config.
--See the pkg-config man page for more details.
--
--To get pkg-config, see <http://pkg-config.freedesktop.org/>.
--See \`config.log' for more details" "$LINENO" 5; }
--
--else
-- GEOCLUE_CFLAGS=$pkg_cv_GEOCLUE_CFLAGS
-- GEOCLUE_LIBS=$pkg_cv_GEOCLUE_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
--
--fi
-
-
- pkg_failed=no
---- gnome-bluetooth-2.32.0.orig/lib/Makefile.in
-+++ gnome-bluetooth-2.32.0/lib/Makefile.in
-@@ -383,7 +383,7 @@
- top_build_prefix = @top_build_prefix@
- top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
--SUBDIRS = plugins
-+SUBDIRS =
- EXTRA_DIST = $(am__append_2) marshal.list bluetooth-client.xml \
- bluetooth-agent.xml obex-agent.xml gnome-bluetooth.symbols
- BUILT_GIRSOURCES = $(am__append_1)