aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-common
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 20:57:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:32:57 -0300
commit55bd7a192e1ddfa4d6eca52aa0b4071b9cd25570 (patch)
treefa27f0e44a8f9f745037f558f43210ce3b2b2434 /community/gnome-common
parent3520952c8f58bed200c585d5d28dc3477b819868 (diff)
downloadaports-55bd7a192e1ddfa4d6eca52aa0b4071b9cd25570.tar.bz2
aports-55bd7a192e1ddfa4d6eca52aa0b4071b9cd25570.tar.xz
community/gnome-common: move from main
Diffstat (limited to 'community/gnome-common')
-rw-r--r--community/gnome-common/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/gnome-common/APKBUILD b/community/gnome-common/APKBUILD
new file mode 100644
index 0000000000..042a80d5d8
--- /dev/null
+++ b/community/gnome-common/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=gnome-common
+pkgver=3.18.0
+pkgrel=1
+pkgdesc="Common development macros for GNOME"
+url="https://www.gnome.org"
+arch="noarch"
+license="GPL"
+source="https://download.gnome.org/sources/gnome-common/${pkgver%.*}/gnome-common-$pkgver.tar.xz"
+builddir="$srcdir"/gnome-common-$pkgver
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="b931c9a6668d996560549738bb2d95f86f56fa68ce930c077275bdc8fddbc2d28d215c1190099db1df851417902fca87ec81f1c0e644c5b9630a175e1cde0719 gnome-common-3.18.0.tar.xz"