aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-contacts/APKBUILD
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:12:14 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 01:29:47 +0200
commit78658881c46e4c182033718536acee582c6cfc8e (patch)
treef4ef0d1af3a72b58373ae6a0f31a6a60ad3c127e /community/gnome-contacts/APKBUILD
parentdbd6a35fe2ee38372e4939ea0238ffedd79aa0ba (diff)
downloadaports-78658881c46e4c182033718536acee582c6cfc8e.tar.bz2
aports-78658881c46e4c182033718536acee582c6cfc8e.tar.xz
community/gnome-contacts: move from testing
Diffstat (limited to 'community/gnome-contacts/APKBUILD')
-rw-r--r--community/gnome-contacts/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/gnome-contacts/APKBUILD b/community/gnome-contacts/APKBUILD
new file mode 100644
index 0000000000..f4a48211d9
--- /dev/null
+++ b/community/gnome-contacts/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnome-contacts
+pkgver=3.34
+pkgrel=0
+pkgdesc="A contacts manager for GNOME"
+url="https://wiki.gnome.org/Apps/Contacts"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="meson vala folks-dev libgee-dev glib-dev gnome-desktop-dev
+ gnome-online-accounts-dev cheese-dev evolution-data-server-dev telepathy-glib-dev
+ libhandy-dev gtk+3.0-dev"
+checkdepends="appstream-glib desktop-file-utils"
+subpackages="$pkgname-lang $pkgname-doc"
+source="https://download.gnome.org/sources/gnome-contacts/$pkgver/gnome-contacts-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="69ea158e52ba0138b523b8dd925e9a729b76f418a82c90ee46a0023fa9d5260afa080540e513f1bc05c34ab9e115733d06eff3f12a05654ab963e3219f9fb128 gnome-contacts-3.34.tar.xz"