aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-disk-utility
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2015-11-09 12:11:12 +0100
commit296090da8ee75a040c496f2caf4102a0fc611acb (patch)
treead2ff20cf54acf9ffcc60fe765ec202c25446c20 /community/gnome-disk-utility
parentf2bc091699e59f7d7cdab90cbba81d7b3f5ee1a8 (diff)
downloadaports-296090da8ee75a040c496f2caf4102a0fc611acb.tar.bz2
aports-296090da8ee75a040c496f2caf4102a0fc611acb.tar.xz
main/gnome-disk-utility: move to community
Diffstat (limited to 'community/gnome-disk-utility')
-rw-r--r--community/gnome-disk-utility/APKBUILD70
-rw-r--r--community/gnome-disk-utility/exp2.patch13
-rw-r--r--community/gnome-disk-utility/fix-freeze.patch32
3 files changed, 115 insertions, 0 deletions
diff --git a/community/gnome-disk-utility/APKBUILD b/community/gnome-disk-utility/APKBUILD
new file mode 100644
index 0000000000..6d909d0a59
--- /dev/null
+++ b/community/gnome-disk-utility/APKBUILD
@@ -0,0 +1,70 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnome-disk-utility
+pkgver=3.16.0
+pkgrel=0
+pkgdesc="GNOME libraries and applications for dealing with storage devices"
+url="http://www.gnome.org"
+arch=""
+license="GPL"
+depends=""
+makedepends="gnome-doc-utils intltool dbus-glib-dev libunique-dev avahi-dev
+ udisks-dev libnotify-dev hicolor-icon-theme libatasmart-dev
+ rarian-dev libxslt"
+install=
+subpackages="$pkgname-dev $pkgname-libs $pkgname-ui-libs:uilibs $pkgname-lang"
+source="http://ftp.gnome.org/pub/GNOME/sources/gnome-disk-utility/${pkgver%.*}/gnome-disk-utility-$pkgver.tar.xz
+ fix-freeze.patch
+ exp2.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+ patch -Np1 -i "$srcdir/fix-freeze.patch"
+ patch -Np1 -i "$srcdir/exp2.patch"
+}
+
+build () {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/gnome-disk-utility \
+ --disable-scrollkeeper \
+ --disable-nautilus \
+ --disable-gtk-doc \
+ || return 1
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libs() {
+ pkgdesc="Shared libraries used by Palimpsest"
+ mkdir -p "$subpkgdir"/usr/lib \
+ "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/lib/libgdu.so.* "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share/
+}
+
+uilibs() {
+ pkgdesc="Shared libraries used by Palimpsest"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libgdu-gtk.so.* "$subpkgdir"/usr/lib/
+}
+
+md5sums="1ba1bec89f2eab29339177c701562ce2 gnome-disk-utility-3.16.0.tar.xz
+c0161b09b620ef9c3975db400518eb1f fix-freeze.patch
+40b82bb896ae40352498ed3dadd2f3d6 exp2.patch"
+sha256sums="b4deed12483dc54627727355cbace05e3a08bb0ac4c2f3319900ff68ff120992 gnome-disk-utility-3.16.0.tar.xz
+818b70360978968457d2c50738347c6726ed8d0c007eb57074881a7e33652526 fix-freeze.patch
+4be207e2c2a6773e3a2f5462929fe2e78352739fc4c5b7d1ee0998583db25710 exp2.patch"
+sha512sums="0c29ddec975953ca14b72ac0a078c8643bf6fcd05103fcb77cbd4fd1866b83ea798c266ebbc61d2670d3a845984555ebe57a14a207183ac10f39d4e5ca1b61a9 gnome-disk-utility-3.16.0.tar.xz
+ba1ed4e5a318938545660f96157c35f901975555434db4f8a539b329b6c3489e84b0f7d5225acc38b30503049419ef79ccffcc0db59a40852cd28da6d17a0bd3 fix-freeze.patch
+e37da782de23287513956b32f6ea36f2ffb6fb7c931479e03171f494212720b34fa780c2d31b0080bb61d5031ee7ca086d366ca852b43ad8fcce92ed22b55b6b exp2.patch"
diff --git a/community/gnome-disk-utility/exp2.patch b/community/gnome-disk-utility/exp2.patch
new file mode 100644
index 0000000000..66e8ce45e8
--- /dev/null
+++ b/community/gnome-disk-utility/exp2.patch
@@ -0,0 +1,13 @@
+diff --git a/src/gdu-gtk/gdu-size-widget.c b/src/gdu-gtk/gdu-size-widget.c
+index 4dd6a8f..715ddad 100644
+--- a/src/gdu-gtk/gdu-size-widget.c
++++ b/src/gdu-gtk/gdu-size-widget.c
+@@ -564,7 +564,7 @@ update_stepping (GduSizeWidget *widget)
+
+ shown_extent = extent / unit_factor;
+
+- increment = (exp10 (floor (log10 (shown_extent))) / 10.0) * unit_factor;
++ increment = (exp (M_LN10 * floor (log10 (shown_extent))) / 10.0) * unit_factor;
+
+ gtk_range_set_increments (GTK_RANGE (widget->priv->hscale),
+ increment,
diff --git a/community/gnome-disk-utility/fix-freeze.patch b/community/gnome-disk-utility/fix-freeze.patch
new file mode 100644
index 0000000000..262748bfb6
--- /dev/null
+++ b/community/gnome-disk-utility/fix-freeze.patch
@@ -0,0 +1,32 @@
+From 82489b51443e1280dfb9fb251ea2693df1809aec Mon Sep 17 00:00:00 2001
+From: Pascal Terjan <pterjan@mandriva.com>
+Date: Mon, 3 May 2010 14:01:22 +0200
+Subject: [PATCH] Force GduPresentable ids to be UTF-8 (#616198)
+
+GduPresentable created in gdu pool include intheir id some strings
+in local encoding like _("Peripheral Devices"). This patch
+enforces them to be UTF-8.
+
+This fixes a crash of gvfs-gdu-volume-monitor when USB devices are
+available on a non UTF-8 system.
+---
+ src/gdu/gdu-pool.c | 3 +++
+ 1 files changed, 3 insertions(+), 0 deletions(-)
+
+diff --git a/src/gdu/gdu-pool.c b/src/gdu/gdu-pool.c
+index bd5eccf..cf6be53 100644
+--- a/src/gdu/gdu-pool.c
++++ b/src/gdu/gdu-pool.c
+@@ -473,6 +473,9 @@ gdu_pool_class_init (GduPoolClass *klass)
+ g_cclosure_marshal_VOID__OBJECT,
+ G_TYPE_NONE, 1,
+ GDU_TYPE_PRESENTABLE);
++#ifdef HAVE_BIND_TEXTDOMAIN_CODESET
++ bind_textdomain_codeset (GETTEXT_PACKAGE, "UTF-8");
++#endif
+ }
+
+ static void
+--
+1.7.1
+