aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-software-plugin-apk
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-19 09:41:54 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-19 07:46:52 +0000
commitbe463923b10a7268117c27c7e5515fc32457918c (patch)
treef1d835f94636ec6b0fccd03aeeb1fc0f73c8a783 /community/gnome-software-plugin-apk
parent4df29baa43ebee3e17b93660da0d15664e1cd3f2 (diff)
downloadaports-be463923b10a7268117c27c7e5515fc32457918c.tar.bz2
aports-be463923b10a7268117c27c7e5515fc32457918c.tar.xz
community/gnome-software-plugin-apk: move from testing
Diffstat (limited to 'community/gnome-software-plugin-apk')
-rw-r--r--community/gnome-software-plugin-apk/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/gnome-software-plugin-apk/APKBUILD b/community/gnome-software-plugin-apk/APKBUILD
new file mode 100644
index 0000000000..e8d0526251
--- /dev/null
+++ b/community/gnome-software-plugin-apk/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnome-software-plugin-apk
+pkgver=0.2.0
+pkgrel=0
+pkgdesc="APK plugin for GNOME Software"
+url="https://github.com/Cogitri/gnome-software-plugin-apk"
+arch="x86_64 aarch64" # apk-polkit
+license="GPL-2.0-or-later"
+makedepends="meson gnome-software-dev gnome-software-static apk-polkit-dev"
+options="!check" # no tests
+source="https://github.com/Cogitri/gnome-software-plugin-apk/archive/v$pkgver/gnome-software-plugin-apk-$pkgver.tar.gz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=plain \
+ . output
+ ninja -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="21d58cd3a4f181b148da951ed1f00a9e45f60ef11b992f0ad5b3d0b434cecef724aa61f5a32b6f91f74765c2d479a3dfa271df2f78137b155d2467c845c4351e gnome-software-plugin-apk-0.2.0.tar.gz"