aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-terminal
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-23 00:37:37 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-23 00:38:16 +0200
commit7d8a4effcef170250573f0b74393d4c4633652cf (patch)
treee94c1b0fde6cac96f64e52b6c120d688a8de1c2f /community/gnome-terminal
parentf136770973b9db434c69ff66a0231e894f78f441 (diff)
downloadaports-7d8a4effcef170250573f0b74393d4c4633652cf.tar.bz2
aports-7d8a4effcef170250573f0b74393d4c4633652cf.tar.xz
community/gnome-terminal: move from testing
Diffstat (limited to 'community/gnome-terminal')
-rw-r--r--community/gnome-terminal/APKBUILD38
-rw-r--r--community/gnome-terminal/fix-W_EXITCODE.patch17
2 files changed, 55 insertions, 0 deletions
diff --git a/community/gnome-terminal/APKBUILD b/community/gnome-terminal/APKBUILD
new file mode 100644
index 0000000000..456a3d33e2
--- /dev/null
+++ b/community/gnome-terminal/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnome-terminal
+pkgver=3.32.2
+pkgrel=0
+pkgdesc="GNOME terminal emulator application"
+url="https://wiki.gnome.org/Apps/Terminal"
+arch="all !aarch64 !armhf !armv7 !s390x" # limited by gnome-shell
+license="GPL-2.0-or-later AND GFDL-1.3-only"
+depends="desktop-file-utils gsettings-desktop-schemas"
+makedepends="dconf-dev gnome-shell gsettings-desktop-schemas-dev nautilus-dev vte3-dev
+ glib-dev intltool itstool"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/gnome-terminal/${pkgver%.*}/gnome-terminal-${pkgver}.tar.xz
+ fix-W_EXITCODE.patch"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --disable-static
+ make
+}
+
+check() {
+ make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="1be1e26b62b9364361982a34455fb5c818a2114edadb1146985f9e418ce5d51387d12b443c12022b8eec9c61c2137a1a780f390672406a1940f8b352b782e3cc gnome-terminal-3.32.2.tar.xz
+21a426f7237a07057b83114282fe302787659ec4a171e894abb3542842403bfedbc051b7b19b48866266aeabaaa8d4590fdec0f058b5255b3309f315ae2f1fa6 fix-W_EXITCODE.patch"
diff --git a/community/gnome-terminal/fix-W_EXITCODE.patch b/community/gnome-terminal/fix-W_EXITCODE.patch
new file mode 100644
index 0000000000..6eda24ae7e
--- /dev/null
+++ b/community/gnome-terminal/fix-W_EXITCODE.patch
@@ -0,0 +1,17 @@
+Source: https://mail-archives.apache.org/mod_mbox/mesos-reviews/201610.mbox/%3C20161014170728.1720.54446@reviews.apache.org%3E
+Upstream: No
+Reason: fixes compilation with musl that doesn't define W* macros.
+
+--- a/src/terminal.c
++++ b/src/terminal.c
+@@ -47,6 +47,10 @@
+ GS_DEFINE_CLEANUP_FUNCTION0(TerminalOptions*, gs_local_options_free, terminal_options_free)
+ #define gs_free_options __attribute__ ((cleanup(gs_local_options_free)))
+
++#ifndef W_EXITCODE
++#define W_EXITCODE(ret, sig) ((ret) << 8 | (sig))
++#endif
++
+ /* Wait-for-exit helper */
+
+ typedef struct {