aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnome-weather
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-06 12:39:38 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-06 13:21:26 +0100
commitf6e843f450a86f69e4ca26dcc321f7661a1fffc8 (patch)
tree7fbfe9fc37451b5d32a8c2db405bc7d8dcb4a739 /community/gnome-weather
parentc96fdfeb90f885c680dde2b7bab5d7c06c9b6977 (diff)
downloadaports-f6e843f450a86f69e4ca26dcc321f7661a1fffc8.tar.bz2
aports-f6e843f450a86f69e4ca26dcc321f7661a1fffc8.tar.xz
community/gnome-weather: move from testing
Diffstat (limited to 'community/gnome-weather')
-rw-r--r--community/gnome-weather/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/gnome-weather/APKBUILD b/community/gnome-weather/APKBUILD
new file mode 100644
index 0000000000..56798c9d84
--- /dev/null
+++ b/community/gnome-weather/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gnome-weather
+pkgver=3.34.0
+pkgrel=0
+pkgdesc="GNOME Weather application"
+url="https://wiki.gnome.org/Apps/Weather"
+arch="noarch !s390x" # missing gjs
+license="GPL-2.0-only"
+makedepends="meson glib-dev gobject-introspection-dev gtk+3.0-dev gjs-dev
+ geoclue-dev libgweather-dev"
+checkdepends="appstream-glib desktop-file-utils"
+subpackages="$pkgname-lang"
+source="https://download.gnome.org/sources/gnome-weather/${pkgver%.*}/gnome-weather-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="f8fd91deef1516b4a18a599415d54a04413a5771916a5c7105e22876e239fe22c325f2e3196f7bff23293893c85fe886fa3a8b4b380aecab62b5b02de58c7185 gnome-weather-3.34.0.tar.xz"