aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnu-libiconv
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-03-07 12:23:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-03-07 12:23:16 +0000
commitb44b46ccee96133867d4e7b7d8588551c491e5ed (patch)
tree3653642daee4786e272cb16843facaa64a65ae5a /community/gnu-libiconv
parent4a95996f8dc329ce7906299085827cd5212f2659 (diff)
downloadaports-b44b46ccee96133867d4e7b7d8588551c491e5ed.tar.bz2
aports-b44b46ccee96133867d4e7b7d8588551c491e5ed.tar.xz
community/gnu-libiconv: mode from testing
Diffstat (limited to 'community/gnu-libiconv')
-rw-r--r--community/gnu-libiconv/APKBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/community/gnu-libiconv/APKBUILD b/community/gnu-libiconv/APKBUILD
new file mode 100644
index 0000000000..b585edc2b5
--- /dev/null
+++ b/community/gnu-libiconv/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnu-libiconv
+pkgver=1.15
+pkgrel=2
+pkgdesc="GNU charset conversion library for libc which doesn't implement it"
+url="https://www.gnu.org/software/libiconv"
+arch="all"
+license='LGPL'
+depends=""
+source="https://ftp.gnu.org/pub/gnu/libiconv/libiconv-$pkgver.tar.gz"
+subpackages="$pkgname-doc $pkgname-dev"
+
+builddir="$srcdir"/libiconv-$pkgver
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --disable-nls \
+ --disable-static
+
+ # work around rpath issue
+ sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
+ sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir/" install
+ rm "$pkgdir"/usr/lib/charset.alias
+
+ # move headers so they dont clash with libc headers
+ mkdir "$pkgdir"/usr/include/gnu-libiconv
+ mv "$pkgdir"/usr/include/*.h "$pkgdir"/usr/include/gnu-libiconv
+ mv "$pkgdir"/usr/bin/iconv "$pkgdir"/usr/bin/gnu-iconv
+
+}
+
+sha512sums="1233fe3ca09341b53354fd4bfe342a7589181145a1232c9919583a8c9979636855839049f3406f253a9d9829908816bb71fd6d34dd544ba290d6f04251376b1a libiconv-1.15.tar.gz"