aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnumeric
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 20:45:03 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 21:23:03 -0300
commitf022104b2104fd121152184948a220851be7a9a6 (patch)
treee4c2345e15f7b4943df5252e1c03b7d437635cee /community/gnumeric
parentb93d42c95e303cb4ff4bceaedefa87ea0c7a73a8 (diff)
downloadaports-f022104b2104fd121152184948a220851be7a9a6.tar.bz2
aports-f022104b2104fd121152184948a220851be7a9a6.tar.xz
community/gnumeric: drop python-loader
Requires python2
Diffstat (limited to 'community/gnumeric')
-rw-r--r--community/gnumeric/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/gnumeric/APKBUILD b/community/gnumeric/APKBUILD
index 1392ea7208..c78c924a73 100644
--- a/community/gnumeric/APKBUILD
+++ b/community/gnumeric/APKBUILD
@@ -1,19 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gnumeric
pkgver=1.12.43
-pkgrel=0
+pkgrel=1
pkgdesc="GNOME Spreadsheet Program"
url="http://www.gnome.org/projects/gnumeric"
arch="all"
license="GPL-2.0-or-later OR GPL-3.0-or-later"
makedepends="gtk+3.0-dev intltool desktop-file-utils goffice-dev rarian
- python2-dev py-gobject3-dev libxslt-dev bison flex itstool
- libxml2-utils autoconf automake libtool"
+ libxslt-dev bison flex itstool libxml2-utils autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+source="https://download.gnome.org/sources/gnumeric/${pkgver%.*}/gnumeric-$pkgver.tar.xz
unbreak-build-by-skipping-cs.patch
"
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare
@@ -21,20 +19,17 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
--localstatedir=/var \
- --disable-static \
- --with-python
+ --disable-static
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}