aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnumeric
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-12-25 12:33:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-12-25 12:33:46 +0000
commit318ad331e239e410b199e29c82e3f412a1b5a1b8 (patch)
tree5a0df46daa6143420fddf71fe60b6bb2bf0b61d9 /community/gnumeric
parent50ecbf794e52b2cb2ed1ba07b83a11c80352a5bf (diff)
downloadaports-318ad331e239e410b199e29c82e3f412a1b5a1b8.tar.bz2
aports-318ad331e239e410b199e29c82e3f412a1b5a1b8.tar.xz
community/{goffice,abiword,gnumeric}: move from main
Diffstat (limited to 'community/gnumeric')
-rw-r--r--community/gnumeric/APKBUILD43
-rw-r--r--community/gnumeric/unbreak-build-by-skipping-cs.patch13
2 files changed, 56 insertions, 0 deletions
diff --git a/community/gnumeric/APKBUILD b/community/gnumeric/APKBUILD
new file mode 100644
index 0000000000..5fb29f124e
--- /dev/null
+++ b/community/gnumeric/APKBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnumeric
+pkgver=1.12.37
+pkgrel=0
+pkgdesc="A GNOME Spreadsheet Program"
+url="http://www.gnome.org/projects/gnumeric/"
+arch="all"
+license="GPL"
+makedepends="gtk+3.0-dev intltool desktop-file-utils goffice-dev rarian
+ python2-dev py-gobject3-dev libxslt-dev bison flex itstool
+ libxml2-utils
+ autoconf automake libtool"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.xz
+ unbreak-build-by-skipping-cs.patch
+ "
+
+builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ autoreconf -vif
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static \
+ --with-python
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="26fb96f2a94f206f20bdd8dba479d34749079d1799e0b03f872c5fff1ac9d4a60c0cfe01d2dc934edea6133f213d390981878ce653586a1efe8b2ca888d49aad gnumeric-1.12.37.tar.xz
+8162b0901e7acf586f4f5be103e2507c17da38ef4e22ce98011dba076de14ea819d346d11917d4d5c70c328b876d890bad2d6b3cede793d218033a59853a0d81 unbreak-build-by-skipping-cs.patch"
diff --git a/community/gnumeric/unbreak-build-by-skipping-cs.patch b/community/gnumeric/unbreak-build-by-skipping-cs.patch
new file mode 100644
index 0000000000..a415d7004d
--- /dev/null
+++ b/community/gnumeric/unbreak-build-by-skipping-cs.patch
@@ -0,0 +1,13 @@
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index 4705b58..fe0abae 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -8,7 +8,7 @@ DISTCLEANFILES=
+ @YELP_HELP_RULES@
+
+ HELP_ID=gnumeric
+-HELP_LINGUAS=cs de es
++HELP_LINGUAS=de es
+ HELP_FILES=gnumeric.xml
+
+ HELP_EXTRA= \