aboutsummaryrefslogtreecommitdiffstats
path: root/community/gnuplot
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2016-10-11 10:58:04 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2016-10-12 16:12:03 +0200
commitaf1dad31f635ba27e6f602413ad335f995243e52 (patch)
treea785afe2500c768549b7c4a4eaef0dc50224114c /community/gnuplot
parent197e4b17fec7cdc0e3b87450bf1ed696ffec4628 (diff)
downloadaports-af1dad31f635ba27e6f602413ad335f995243e52.tar.bz2
aports-af1dad31f635ba27e6f602413ad335f995243e52.tar.xz
community/gnuplot: move from testing
Diffstat (limited to 'community/gnuplot')
-rw-r--r--community/gnuplot/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/community/gnuplot/APKBUILD b/community/gnuplot/APKBUILD
new file mode 100644
index 0000000000..3a9e129b84
--- /dev/null
+++ b/community/gnuplot/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=gnuplot
+pkgver=5.0.5
+pkgrel=0
+pkgdesc="Utility for plotting graphs"
+url="http://www.gnuplot.info/"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="cairo-dev pango-dev gd-dev lua5.2-dev readline-dev
+ libpng-dev libjpeg-turbo-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/gnuplot/gnuplot/$pkgver/gnuplot-$pkgver.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --enable-stats \
+ --disable-wxwidgets \
+ --disable-qt \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 BUGS ChangeLog NEWS PGPKEYS PORTING README* \
+ "$pkgdir"/usr/share/doc/$pkgname/ || return 1
+}
+
+md5sums="c5e96fca73afbee4f57cbc1bfce6b3b8 gnuplot-5.0.5.tar.gz"
+sha256sums="25f3e0bf192e01115c580f278c3725d7a569eb848786e12b455a3fda70312053 gnuplot-5.0.5.tar.gz"
+sha512sums="fd6efc3a869850fa1939a4c833c776395efaaaf6dccc63e3626cee2e39938923b06314368802155adf711ae3e5ca0e3dd1a88be348e8571f9d0be8790240c62c gnuplot-5.0.5.tar.gz"