aboutsummaryrefslogtreecommitdiffstats
path: root/community/go-bootstrap
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-01-15 05:17:12 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 10:45:04 +0000
commit15ce033036d4755eea263f73562085840a63a401 (patch)
tree3ca5d982eaa9dea3b0a48857b0a204ec9571555c /community/go-bootstrap
parentfad9a11100fcbcd984630cce25c013b79736d086 (diff)
downloadaports-15ce033036d4755eea263f73562085840a63a401.tar.bz2
aports-15ce033036d4755eea263f73562085840a63a401.tar.xz
community/go-bootstrap: remove unsupported archs
go-1.4.3 supports only 386, amd64, arm (32-bit) so: - remove mips*, the specs are incomplete even for later mips-aware versions of go; - pass correct option for 386 FPU, otherwise it is autodetected at build time (to sse2); - pass ARM architecture version explicitly for arm*; This change affects the x86 package so bump pkgrel.
Diffstat (limited to 'community/go-bootstrap')
-rw-r--r--community/go-bootstrap/APKBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/community/go-bootstrap/APKBUILD b/community/go-bootstrap/APKBUILD
index 9b46f0783c..54b36f0ace 100644
--- a/community/go-bootstrap/APKBUILD
+++ b/community/go-bootstrap/APKBUILD
@@ -4,10 +4,10 @@
pkgname=go-bootstrap
_realname="${pkgname%-*}"
pkgver=1.4.3
-pkgrel=2
+pkgrel=3
pkgdesc="Go programming language compiler used for bootstraping"
url="http://www.golang.org/"
-arch="all !aarch64 !ppc64le !s390x"
+arch="armel armhf armv7 x86 x86_64"
license="BSD"
depends=""
depends_dev=""
@@ -39,13 +39,11 @@ build() {
export CGO_ENABLED=0
case "$CARCH" in
- x86) export GOARCH="386" ;;
+ armel) export GOARCH="arm" GOARM="5" ;;
+ armhf) export GOARCH="arm" GOARM="6" ;;
+ armv7) export GOARCH="arm" GOARM="7" ;;
+ x86) export GOARCH="386" GO386="387" ;;
x86_64) export GOARCH="amd64" ;;
- arm*) export GOARCH="arm" ;;
- mips) export GOARCH="mips" ;;
- mips64) export GOARCH="mips64" ;;
- mips64el) export GOARCH="mips64le" ;;
- mipsel) export GOARCH="mipsle" ;;
*) return 1 ;;
esac