aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authoralpine-mips-patches <info@mobile-stream.com>2019-01-15 05:19:10 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 11:23:13 +0000
commit1274258888a7d522f8bc6d19c7f476e2e2fd4470 (patch)
treea7b929a9df77a624e592e8708f27223562aa6f91 /community/go
parent2caf0650b29c3f0125469bc979c3cb3dc13a4c5a (diff)
downloadaports-1274258888a7d522f8bc6d19c7f476e2e2fd4470.tar.bz2
aports-1274258888a7d522f8bc6d19c7f476e2e2fd4470.tar.xz
community/go: enable build on armel
There were ARMv5TE boards with 512 MiB (as in RPi1), that is enough for go. Also remove go-bootstrap from makedepends. In a cross-build it ends up with depending on itself which is safe (abuild handles this) but ugly. In normal build it is duplicated which is safe but ugly too. Do not bump pkgrel since - no previous armel packages exist; - makedepends change makes no difference for the created apks.
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index c148f309ed..ea39f58e8c 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -9,7 +9,7 @@ arch="all"
license="BSD"
depends="binutils gcc"
depends_dev=""
-makedepends="bash go-bootstrap"
+makedepends="bash"
install=""
subpackages="$pkgname-doc"
source="https://golang.org/dl/go${pkgver/_/}.src.tar.gz
@@ -50,6 +50,7 @@ fi
case "$CTARGET_ARCH" in
aarch64)export GOARCH="arm64" ;;
+armel) export GOARCH="arm" GOARM=5 ;;
armhf) export GOARCH="arm" GOARM=6 ;;
armv7) export GOARCH="arm" GOARM=7 ;;
s390x) export GOARCH="s390x" ;;