aboutsummaryrefslogtreecommitdiffstats
path: root/community/go
diff options
context:
space:
mode:
authorWolf <wolf@wolfsden.cz>2019-09-24 20:24:27 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-11-01 18:14:08 +0000
commit614532c3d03945825150debba48b6bf624b6a634 (patch)
tree9cf2dc197c309d66bbd6675c200332368355090a /community/go
parentdf1d940c02b63fb97a6881fa1b13c0161fa86820 (diff)
downloadaports-614532c3d03945825150debba48b6bf624b6a634.tar.bz2
aports-614532c3d03945825150debba48b6bf624b6a634.tar.xz
community/go: Add musl-dev as dependency
Installing and trying to use go in clean base image lead to /tmp # go run test.go loadinternal: cannot find runtime/cgo /usr/lib/go/pkg/tool/linux_amd64/link: running gcc failed: exit status 1 /usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-linux-musl/bin/ld: cannot find Scrt1.o: No such file or directory /usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-linux-musl/bin/ld: cannot find crti.o: No such file or directory /usr/lib/gcc/x86_64-alpine-linux-musl/8.3.0/../../../../x86_64-alpine-linux-musl/bin/ld: cannot find -lssp_nonshared collect2: error: ld returned 1 exit status which is fixed by installing musl-dev.
Diffstat (limited to 'community/go')
-rw-r--r--community/go/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/community/go/APKBUILD b/community/go/APKBUILD
index 671b08f0e3..167c855e9e 100644
--- a/community/go/APKBUILD
+++ b/community/go/APKBUILD
@@ -4,12 +4,12 @@
pkgname=go
# go binaries are statically linked, security updates require rebuilds
pkgver=1.13.3
-pkgrel=0
+pkgrel=1
pkgdesc="Go programming language compiler"
url="https://golang.org/"
arch="all"
license="BSD-3-Clause"
-depends="binutils gcc"
+depends="binutils gcc musl-dev"
makedepends="bash"
checkdepends="binutils-gold"
subpackages="$pkgname-doc"