aboutsummaryrefslogtreecommitdiffstats
path: root/community/gotop
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-11 06:29:39 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 06:29:39 -0300
commit84b2ead0864f63eeca05ed5279fde73c7c48687c (patch)
treeab4ada3c06497b82bbd672a5e6f745b20455d173 /community/gotop
parentd2c7c7a309e45d52b70aff5eb027b9ae77648b8c (diff)
downloadaports-84b2ead0864f63eeca05ed5279fde73c7c48687c.tar.bz2
aports-84b2ead0864f63eeca05ed5279fde73c7c48687c.tar.xz
community/gotop: fix build with new go
Diffstat (limited to 'community/gotop')
-rw-r--r--community/gotop/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/community/gotop/APKBUILD b/community/gotop/APKBUILD
index 86b9b86836..b1a0f49b31 100644
--- a/community/gotop/APKBUILD
+++ b/community/gotop/APKBUILD
@@ -8,7 +8,7 @@ arch="all"
license="AGPL-3.0-or-later"
depends="procps" # Remove once #138 on cjbassi/gotop is fixed
makedepends="git go"
-source="$pkgname-$pkgver.tar.gz::https://github.com/cjbassi/gotop/archive/${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cjbassi/gotop/archive/$pkgver.tar.gz"
builddir="$srcdir/src/github.com/cjbassi/gotop"
prepare() {
@@ -29,4 +29,9 @@ check() {
package() {
install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
}
+
+cleanup_srcdir() {
+ go clean -modcache
+ default_cleanup_srcdir
+}
sha512sums="012cc627fa7013409f3775d5bf2528e25e275fc285fea7ae93a1afec33474c923cc6cd9accb24fce479ab229c98d6438cc9f5eb7dea37f72c1905516d5fdbf6e gotop-3.0.0.tar.gz"