aboutsummaryrefslogtreecommitdiffstats
path: root/community/gource
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-26 07:45:08 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-26 07:45:08 +0000
commitc5240dc4d2a5efc26b94c943d87848e51ba2794b (patch)
tree1c7c1bb9b5ca99e0afaaa093a8818fd8e63f423d /community/gource
parent4a2a6ce1a143e0983ca0d6ca754a2e0702504ca5 (diff)
downloadaports-c5240dc4d2a5efc26b94c943d87848e51ba2794b.tar.bz2
aports-c5240dc4d2a5efc26b94c943d87848e51ba2794b.tar.xz
community/gource: moved from testing
Diffstat (limited to 'community/gource')
-rw-r--r--community/gource/APKBUILD30
-rw-r--r--community/gource/logmill.patch11
2 files changed, 41 insertions, 0 deletions
diff --git a/community/gource/APKBUILD b/community/gource/APKBUILD
new file mode 100644
index 0000000000..486b40128f
--- /dev/null
+++ b/community/gource/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolistæ@alpinelinux.org>
+pkgname=gource
+pkgver=0.44
+pkgrel=0
+pkgdesc="Software version control visualization"
+url="http://gource.io/"
+arch="all"
+license="GPL3"
+depends=
+makedepends="ftgl-dev sdl2-dev sdl2_image-dev pcre-dev glew-dev libpng-dev
+ libjpeg-turbo-dev glu-dev boost-dev glm-dev"
+subpackages="$pkgname-doc"
+source="https://github.com/acaudwell/Gource/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="b0f13a524e3391bfc41f12c624da1e00 gource-0.44.tar.gz"
+sha256sums="2604ca4442305ffdc5bb1a7bac07e223d59c846f93567be067e8dfe2f42f097c gource-0.44.tar.gz"
+sha512sums="4cdc7824f8f5b4aa7004135e59157ebf731730bc2dab0120ab919240576939b0e13dc6a09df79fcdb55cc7b4628c3887f5eca7ab0fa73d5e7bf5ad49c7cf898c gource-0.44.tar.gz"
diff --git a/community/gource/logmill.patch b/community/gource/logmill.patch
new file mode 100644
index 0000000000..4ed4e998f9
--- /dev/null
+++ b/community/gource/logmill.patch
@@ -0,0 +1,11 @@
+--- ./src/logmill.cpp.orig
++++ ./src/logmill.cpp
+@@ -176,7 +176,7 @@ RCommitLog* RLogMill::fetchLog(std::string& log_format) {
+ logfile = repo_path.string();
+ }
+ }
+- } catch(boost::filesystem3::filesystem_error& error) {
++ } catch(boost::filesystem::filesystem_error& error) {
+ }
+ }
+