aboutsummaryrefslogtreecommitdiffstats
path: root/community/gpgme
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-05-29 11:29:53 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-05 19:38:55 +0000
commit2c548e7ab08477bbe469934f951bcb41b5e020e2 (patch)
tree13ba3a8aa56fa26ab57f8c39984b75b3a1d8a654 /community/gpgme
parentc94cc7937707f98d47c2067df2e058a09e264c17 (diff)
downloadaports-2c548e7ab08477bbe469934f951bcb41b5e020e2.tar.bz2
aports-2c548e7ab08477bbe469934f951bcb41b5e020e2.tar.xz
community/gpgme: move from main
Diffstat (limited to 'community/gpgme')
-rw-r--r--community/gpgme/0001-Disable-failing-tests-x86-armhf.patch83
-rw-r--r--community/gpgme/APKBUILD58
2 files changed, 141 insertions, 0 deletions
diff --git a/community/gpgme/0001-Disable-failing-tests-x86-armhf.patch b/community/gpgme/0001-Disable-failing-tests-x86-armhf.patch
new file mode 100644
index 0000000000..bcee1c45b4
--- /dev/null
+++ b/community/gpgme/0001-Disable-failing-tests-x86-armhf.patch
@@ -0,0 +1,83 @@
+From bed4c45433fb0b8d77be85ea63fe2dfb6ffae7eb Mon Sep 17 00:00:00 2001
+From: Leonardo Arena <rnalrd@alpinelinux.org>
+Date: Fri, 9 Nov 2018 14:58:21 +0000
+Subject: [PATCH] Disable failing tests (x86, armhf)
+
+starting gpg-agent..
+OK
+Using gpg module from '/home/buildozer/aports/main/gpgme/src/gpgme-1.12.0/lang/python/python3-gpg/lib.linux-i686-3.6/gpg'.
+Traceback (most recent call last):
+ File "./t-callbacks.py", line 114, in <module>
+ c.op_genkey(parms, None, None)
+ File "/home/buildozer/aports/main/gpgme/src/gpgme-1.12.0/lang/python/python3-gpg/lib.linux-i686-3.6/gpg/core.py", line 158, in wrapper
+ return _funcwrap(self, *args)
+ File "/home/buildozer/aports/main/gpgme/src/gpgme-1.12.0/lang/python/python3-gpg/lib.linux-i686-3.6/gpg/core.py", line 141, in _funcwrap
+ return errorcheck(result, name)
+ File "/home/buildozer/aports/main/gpgme/src/gpgme-1.12.0/lang/python/python3-gpg/lib.linux-i686-3.6/gpg/errors.py", line 129, in errorcheck
+ raise GPGMEError(retval, extradata)
+gpg.errors.GPGMEError: gpgme_op_genkey: GPGME: General error
+stopping gpg-agent
+Running tests using /usr/bin/python3 (3.6)...
+PASS: initial.py
+PASS: t-wrapper.py
+FAIL: t-callbacks.py
+PASS: t-data.py
+PASS: t-encrypt.py
+PASS: t-encrypt-sym.py
+PASS: t-encrypt-sign.py
+PASS: t-sign.py
+PASS: t-signers.py
+PASS: t-decrypt.py
+PASS: t-verify.py
+PASS: t-decrypt-verify.py
+PASS: t-sig-notation.py
+PASS: t-export.py
+PASS: t-import.py
+PASS: t-trustlist.py
+PASS: t-edit.py
+PASS: t-keylist.py
+PASS: t-keylist-from-data.py
+PASS: t-wait.py
+PASS: t-encrypt-large.py
+PASS: t-file-name.py
+PASS: t-idiomatic.py
+PASS: t-protocol-assuan.py
+PASS: t-quick-key-creation.py
+PASS: t-quick-subkey-creation.py
+PASS: t-quick-key-manipulation.py
+PASS: t-quick-key-signing.py
+PASS: final.py
+29 tests run, 28 succeeded, 1 failed, 0 skipped.
+
+---
+ lang/python/tests/Makefile.am | 1 -
+ lang/python/tests/Makefile.in | 1 -
+ 2 files changed, 2 deletions(-)
+
+diff --git a/lang/python/tests/Makefile.am b/lang/python/tests/Makefile.am
+index d26d33d..f6979bf 100644
+--- a/lang/python/tests/Makefile.am
++++ b/lang/python/tests/Makefile.am
+@@ -29,7 +29,6 @@ TESTS_ENVIRONMENT = GNUPGHOME=$(GNUPGHOME) \
+ LD_LIBRARY_PATH="../../../src/.libs:$(LD_LIBRARY_PATH)"
+
+ py_tests = t-wrapper.py \
+- t-callbacks.py \
+ t-data.py \
+ t-encrypt.py \
+ t-encrypt-sym.py \
+diff --git a/lang/python/tests/Makefile.in b/lang/python/tests/Makefile.in
+index 9efd7ee..d840daa 100644
+--- a/lang/python/tests/Makefile.in
++++ b/lang/python/tests/Makefile.in
+@@ -342,7 +342,6 @@ TESTS_ENVIRONMENT = GNUPGHOME=$(GNUPGHOME) \
+ LD_LIBRARY_PATH="../../../src/.libs:$(LD_LIBRARY_PATH)"
+
+ py_tests = t-wrapper.py \
+- t-callbacks.py \
+ t-data.py \
+ t-encrypt.py \
+ t-encrypt-sym.py \
+--
+2.19.1
+
diff --git a/community/gpgme/APKBUILD b/community/gpgme/APKBUILD
new file mode 100644
index 0000000000..cf9bb482ee
--- /dev/null
+++ b/community/gpgme/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor:
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gpgme
+pkgver=1.13.0
+pkgrel=1
+pkgdesc="gnupg made easy"
+url="https://www.gnupg.org/related_software/gpgme/"
+arch="all"
+license="LGPL-2.1-or-later GPL-3.0-or-later"
+depends="gnupg"
+depends_dev="libgpg-error-dev libassuan-dev"
+makedepends="$depends_dev python3-dev py3-setuptools swig"
+subpackages="$pkgname-dev $pkgname-doc gpgmepp py3-gpgme:py3"
+source="https://www.gnupg.org/ftp/gcrypt/$pkgname/$pkgname-$pkgver.tar.bz2
+ 0001-Disable-failing-tests-x86-armhf.patch
+ "
+builddir="$srcdir"/gpgme-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --enable-languages="cl cpp python"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+gpgmepp() {
+ pkgdesc="C++ bindings for GPGME"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libgpgmepp.so.* "$subpkgdir"/usr/lib/
+}
+
+py3() {
+ pkgdesc="Python 3 bindings for $pkgname"
+ depends="$depends $pkgname python3"
+
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/python3* "$subpkgdir"/usr/lib/
+}
+
+sha512sums="47a7a67dcc6d111cddd805d288d42e870948114a6dc09ce0675ad8b3d1580bbc2a683e1e70cb2f416919cf2129c72a9ff30e2e3b9527809d04e863cc1f87267b gpgme-1.13.0.tar.bz2
+9a461042175e8771b685967059c8760050094925a4a577b62d2a4a3c5a4c135e857aa812f5cf6019241e73c941837ad449a9c51b41fd661957026b0ae9c1198c 0001-Disable-failing-tests-x86-armhf.patch"