aboutsummaryrefslogtreecommitdiffstats
path: root/community/gpicview
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 20:56:38 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:32:57 -0300
commita9fea2070892bca32a3639a6723f41d78c48ac89 (patch)
treea47163a94b2c8c9e33c61abc320a63154802ff0e /community/gpicview
parent9d8c2488de59cb1e0632225b420eb3bfd4d4cb84 (diff)
downloadaports-a9fea2070892bca32a3639a6723f41d78c48ac89.tar.bz2
aports-a9fea2070892bca32a3639a6723f41d78c48ac89.tar.xz
community/gpicview: move from main
Diffstat (limited to 'community/gpicview')
-rw-r--r--community/gpicview/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/community/gpicview/APKBUILD b/community/gpicview/APKBUILD
new file mode 100644
index 0000000000..c0a76bdc75
--- /dev/null
+++ b/community/gpicview/APKBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gpicview
+pkgver=0.2.5
+pkgrel=1
+pkgdesc="Picture viewer of the LXDE Desktop"
+url="https://wiki.lxde.org/en/GPicView"
+arch="all"
+license="GPL-2.0-or-later"
+subpackages="$pkgname-lang"
+makedepends="gtk+-dev intltool libjpeg-turbo-dev"
+source="https://downloads.sourceforge.net/project/lxde/GPicView%20%28image%20Viewer%29/${pkgver%.*}.x/gpicview-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --sysconfdir=/etc \
+ --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="afc7e67c7ae1252f9c1816ee46fe69e96ea7be9a60e03406a539f17b2e4f0e4b93a028c6f3f1c455f5433d6d7d78a58dcee2cb0ac91ea53093a21935bf454afd gpicview-0.2.5.tar.xz"