aboutsummaryrefslogtreecommitdiffstats
path: root/community/grantlee-editor
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-04-13 11:25:16 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-14 15:45:17 +0000
commit966927e82a2e0daca7e14d2e2a09bd629a65c3a1 (patch)
tree25fd09f53989d16b567eafec945198ff616ea32c /community/grantlee-editor
parentd4230ca4cf48094666136e1a3b45cfa01615d618 (diff)
downloadaports-966927e82a2e0daca7e14d2e2a09bd629a65c3a1.tar.bz2
aports-966927e82a2e0daca7e14d2e2a09bd629a65c3a1.tar.xz
community/grantlee-editor: move from testing
Diffstat (limited to 'community/grantlee-editor')
-rw-r--r--community/grantlee-editor/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/grantlee-editor/APKBUILD b/community/grantlee-editor/APKBUILD
new file mode 100644
index 0000000000..b96a5ea3f4
--- /dev/null
+++ b/community/grantlee-editor/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=grantlee-editor
+pkgver=19.12.3
+pkgrel=0
+arch="all !ppc64le !s390x !armhf !mips !mips64" # Limited by qt5-qtwebengine
+url="https://kontact.kde.org/"
+pkgdesc="Utilities and tools to manage themes in KDE PIM applications "
+license="GPL-2.0-or-later AND GFDL-1.2-only"
+makedepends="extra-cmake-modules qt5-qtbase-dev qt5-qtwebengine-dev kcrash-dev kdbusaddons-dev kdoctools-dev kxmlgui-dev ktexteditor-dev knewstuff-dev karchive-dev pimcommon-dev messagelib-dev grantleetheme-dev akonadi-mime-dev libkleo-dev kimap-dev kpimtextedit-dev syntax-highlighting-dev qgpgme"
+source="https://download.kde.org/stable/release-service/$pkgver/src/grantlee-editor-$pkgver.tar.xz"
+subpackages="$pkgname-doc $pkgname-lang"
+
+build() {
+ cmake -B build \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make -C build
+}
+
+check() {
+ cd build
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C build install
+}
+
+sha512sums="03279e4bd93a50d09d724baee931ec7f3b6827e44f7408555ac00fff1d04b2a6b60fd8c18d4dc8480b32c878d367b8c012e030b77a127d863280a07039517f29 grantlee-editor-19.12.3.tar.xz"