aboutsummaryrefslogtreecommitdiffstats
path: root/community/graphene
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-12-06 12:43:30 +0100
committerRasmus Thomsen <oss@cogitri.dev>2019-12-06 13:22:32 +0100
commit8af1f0864dad4a62003952f024e7cf794f612ad4 (patch)
tree065ba3da9130fe0eff0b4f6e20931e1e893ff943 /community/graphene
parentf6e843f450a86f69e4ca26dcc321f7661a1fffc8 (diff)
downloadaports-8af1f0864dad4a62003952f024e7cf794f612ad4.tar.bz2
aports-8af1f0864dad4a62003952f024e7cf794f612ad4.tar.xz
community/graphene: move from testing
Diffstat (limited to 'community/graphene')
-rw-r--r--community/graphene/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/graphene/APKBUILD b/community/graphene/APKBUILD
new file mode 100644
index 0000000000..a568202ab7
--- /dev/null
+++ b/community/graphene/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname="graphene"
+pkgver="1.10.0"
+pkgrel=0
+pkgdesc="A thin layer of graphic data types"
+url="http://ebassi.github.io/graphene/"
+arch="all"
+license="MIT"
+makedepends="meson glib-dev gobject-introspection-dev"
+subpackages="$pkgname-dev"
+source="https://download.gnome.org/sources/graphene/${pkgver%.*}/graphene-$pkgver.tar.xz"
+
+build() {
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Dinstalled_tests=false \
+ . output
+ ninja -C output
+}
+
+check() {
+ ninja -C output test
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+sha512sums="842ac2c9c2046f07f8421b99292cac348276bb1e025250c7e0dc3ec7f90cb33094b765034862f325dd78f93aa5484ad75a4ad6139fe13330d9e41e3a7cb830d0 graphene-1.10.0.tar.xz"