aboutsummaryrefslogtreecommitdiffstats
path: root/community/greenbone-security-assistant/001-fortify-source.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 10:01:53 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-19 11:24:37 +0000
commit6b5a28e2c37efc9a6753c306c3400da5d1d966b2 (patch)
tree0745dbbb59ff780cb12fe3af612e5014dc93d4eb /community/greenbone-security-assistant/001-fortify-source.patch
parent1ccb7c0c01a3eea05bbf0139b6e91a3c88cb2ed3 (diff)
downloadaports-6b5a28e2c37efc9a6753c306c3400da5d1d966b2.tar.bz2
aports-6b5a28e2c37efc9a6753c306c3400da5d1d966b2.tar.xz
community/greenbone-security-assistant: moved from testing
Diffstat (limited to 'community/greenbone-security-assistant/001-fortify-source.patch')
-rw-r--r--community/greenbone-security-assistant/001-fortify-source.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/greenbone-security-assistant/001-fortify-source.patch b/community/greenbone-security-assistant/001-fortify-source.patch
new file mode 100644
index 0000000000..afd1af231d
--- /dev/null
+++ b/community/greenbone-security-assistant/001-fortify-source.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 549833c..a4e7882 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -487,7 +487,7 @@ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/zones.xml
+
+ ## Program
+
+-set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
++set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
+
+ set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
+ set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall")