aboutsummaryrefslogtreecommitdiffstats
path: root/community/greenbone-security-assistant
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-03-09 14:50:27 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-03-09 14:50:49 +0000
commit0bcfc95639bac88d738ef53264b4196865f3a8a3 (patch)
treedadee2ca146890870529e063d444aa7db0d69492 /community/greenbone-security-assistant
parentf1315f394671ec8b6f60f7294ac8a409c98df434 (diff)
downloadaports-0bcfc95639bac88d738ef53264b4196865f3a8a3.tar.bz2
aports-0bcfc95639bac88d738ef53264b4196865f3a8a3.tar.xz
community/greenbone-security-assistant: fixed segfault due to stack assuming is a glibc distro
Diffstat (limited to 'community/greenbone-security-assistant')
-rw-r--r--community/greenbone-security-assistant/003-musl-stack-size.patch27
-rw-r--r--community/greenbone-security-assistant/APKBUILD8
2 files changed, 32 insertions, 3 deletions
diff --git a/community/greenbone-security-assistant/003-musl-stack-size.patch b/community/greenbone-security-assistant/003-musl-stack-size.patch
new file mode 100644
index 0000000000..686cdcd453
--- /dev/null
+++ b/community/greenbone-security-assistant/003-musl-stack-size.patch
@@ -0,0 +1,27 @@
+diff -ru greenbone-security-assistant-7.0.2.orig/src/gsad.c greenbone-security-assistant-7.0.2/src/gsad.c
+--- greenbone-security-assistant-7.0.2.orig/src/gsad.c 2017-03-09 15:59:19.000000000 +0200
++++ greenbone-security-assistant-7.0.2/src/gsad.c 2017-03-09 16:17:28.506470054 +0200
+@@ -5488,6 +5488,7 @@
+ NULL, NULL, handler, NULL, MHD_OPTION_NOTIFY_COMPLETED,
+ free_resources, NULL, MHD_OPTION_LISTEN_SOCKET, unix_socket,
+ MHD_OPTION_PER_IP_CONNECTION_LIMIT, 30,
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
+ MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL, MHD_OPTION_END);
+ }
+
+@@ -5513,6 +5514,7 @@
+ (MHD_USE_THREAD_PER_CONNECTION | MHD_USE_DEBUG | ipv6_flag, port,
+ NULL, NULL, handler, NULL, MHD_OPTION_NOTIFY_COMPLETED,
+ free_resources, NULL, MHD_OPTION_SOCK_ADDR, address,
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
+ MHD_OPTION_PER_IP_CONNECTION_LIMIT, 30,
+ MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL, MHD_OPTION_END);
+ }
+@@ -5540,6 +5542,7 @@
+ MHD_OPTION_HTTPS_MEM_CERT, cert,
+ MHD_OPTION_NOTIFY_COMPLETED, free_resources, NULL,
+ MHD_OPTION_SOCK_ADDR, address,
++ MHD_OPTION_THREAD_STACK_SIZE, (size_t) 4*1024*1024,
+ MHD_OPTION_PER_IP_CONNECTION_LIMIT, 30,
+ MHD_OPTION_HTTPS_PRIORITIES, priorities,
+ MHD_OPTION_EXTERNAL_LOGGER, mhd_logger, NULL,
diff --git a/community/greenbone-security-assistant/APKBUILD b/community/greenbone-security-assistant/APKBUILD
index b5bbfff294..d39423fa86 100644
--- a/community/greenbone-security-assistant/APKBUILD
+++ b/community/greenbone-security-assistant/APKBUILD
@@ -4,7 +4,7 @@ pkgname=greenbone-security-assistant
_pkgname=gsad
pkgver=7.0.2
_pkgid=2429
-pkgrel=2
+pkgrel=3
pkgdesc="Greenbone Security Assistant (gsa) - OpenVAS web frontend"
url="http://www.openvas.org/"
arch="all"
@@ -18,7 +18,8 @@ source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar
$_pkgname.logrotate
000-sys_siglist.patch
001-malloc-trim.patch
- 002-cmakelist.patch"
+ 002-cmakelist.patch
+ 003-musl-stack-size.patch"
builddir="$srcdir"/$pkgname-$pkgver
@@ -46,4 +47,5 @@ aea96cef16ca7a63570c2d94a1fc7ef27d4163c28e1d729fd11821295f88a96864add0146d407e7b
0d459084f95e00dfb06912b9d89af011fac117a32687ffd3da3887c24e80c074b681c0d87532a4a7511e42c540f8d8b2ceaa04208fff531b94047a08decddd0f gsad.logrotate
7074ab472761d44f401dd34feeba62c5c47f97ec9aec9a8be51bc1ceb8d32ebd4de162fb6563cd58859354dccd3f3874e5012433c81e45bfaab368188a9b481f 000-sys_siglist.patch
e2cf8dd79a029d8c6dd7c3a67424a1b345da60582eedc7419395a751a118d0e2fbf21cd7e68db81ae5e403858107a9ecbbd4aaafa3f2b851a77c6ab953ed0dd8 001-malloc-trim.patch
-6752bb6834811fc7c1259d2c8a0ae5f25a01de881008f6f6635b1f7a43672b5c1862de5b3591f81d7a2f22258614b71bb6ab588a3930648d9d74ef8a75d28c92 002-cmakelist.patch"
+6752bb6834811fc7c1259d2c8a0ae5f25a01de881008f6f6635b1f7a43672b5c1862de5b3591f81d7a2f22258614b71bb6ab588a3930648d9d74ef8a75d28c92 002-cmakelist.patch
+509cecb54f00e09fad87cca783ba4fc0b7115be903056170884501ddbb97ec00c76c3c9369a54b6ab14e0429aa3fe2ea7c8ec091334d9b66767457075f48e4bb 003-musl-stack-size.patch"