aboutsummaryrefslogtreecommitdiffstats
path: root/community/greenbone-security-assistant
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 12:26:26 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-18 12:26:26 +0000
commit98ef3e0c31fdf242f8e552650904cf3ff971392c (patch)
treea8065194149d856421cdeaed7b0765ceae22547e /community/greenbone-security-assistant
parentbe78d04ddff3f9f3dba8fba9aafda325b6ccc48a (diff)
downloadaports-98ef3e0c31fdf242f8e552650904cf3ff971392c.tar.bz2
aports-98ef3e0c31fdf242f8e552650904cf3ff971392c.tar.xz
Revert "community/greenbone-security-assistant: moved from testing"
Diffstat (limited to 'community/greenbone-security-assistant')
-rw-r--r--community/greenbone-security-assistant/001-fortify-source.patch13
-rw-r--r--community/greenbone-security-assistant/002-sys_siglist.patch13
-rw-r--r--community/greenbone-security-assistant/APKBUILD72
-rw-r--r--community/greenbone-security-assistant/gsad.confd8
-rw-r--r--community/greenbone-security-assistant/gsad.initd16
-rw-r--r--community/greenbone-security-assistant/gsad.logrotate11
6 files changed, 0 insertions, 133 deletions
diff --git a/community/greenbone-security-assistant/001-fortify-source.patch b/community/greenbone-security-assistant/001-fortify-source.patch
deleted file mode 100644
index afd1af231d..0000000000
--- a/community/greenbone-security-assistant/001-fortify-source.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 549833c..a4e7882 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -487,7 +487,7 @@ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/zones.xml
-
- ## Program
-
--set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
-+set (HARDENING_FLAGS "-Wformat -Wformat-security -O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector -Wl,-z,relro -Wl,-z,now")
-
- set (CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -Werror")
- set (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${HARDENING_FLAGS} -Wall")
diff --git a/community/greenbone-security-assistant/002-sys_siglist.patch b/community/greenbone-security-assistant/002-sys_siglist.patch
deleted file mode 100644
index e5720e57f6..0000000000
--- a/community/greenbone-security-assistant/002-sys_siglist.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/gsad.c b/src/gsad.c
-index 7536183..4722a8d 100644
---- a/src/gsad.c
-+++ b/src/gsad.c
-@@ -5296,7 +5296,7 @@ main (int argc, char **argv)
- if (termination_signal)
- {
- g_log (G_LOG_DOMAIN, G_LOG_LEVEL_DEBUG, "Received %s signal.\n",
-- sys_siglist[termination_signal]);
-+ strsignal(termination_signal));
- gsad_cleanup ();
- /* Raise signal again, to exit with the correct return value. */
- signal (termination_signal, SIG_DFL);
diff --git a/community/greenbone-security-assistant/APKBUILD b/community/greenbone-security-assistant/APKBUILD
deleted file mode 100644
index c7dea9131e..0000000000
--- a/community/greenbone-security-assistant/APKBUILD
+++ /dev/null
@@ -1,72 +0,0 @@
-# Contributor: Francesco Colista <fcolista@alpinelinux.org>
-# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=greenbone-security-assistant
-_pkgname=gsad
-pkgver=6.0.10
-_pkgid=2299
-pkgrel=3
-pkgdesc="Greenbone Security Assistant (gsa) - OpenVAS web frontend"
-url="http://www.openvas.org/"
-arch="all"
-license="GPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev cmake doxygen xmltoman openvas-libraries-dev
- libxslt-dev libmicrohttpd-dev"
-install=""
-subpackages="$pkgname-doc $pkgname-lang"
-source="http://wald.intevation.org/frs/download.php/$_pkgid/$pkgname-$pkgver.tar.gz
- $_pkgname.initd
- $_pkgname.confd
- $_pkgname.logrotate
- 001-fortify-source.patch
- 002-sys_siglist.patch"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- cmake -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DSYSCONFDIR=/etc \
- -DSBINDIR=/usr/bin \
- -DLOCALSTATEDIR=/var .
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/$_pkgname.logrotate" "$pkgdir/etc/logrotate.d/$_pkgname"
- install -Dm755 "$srcdir/$_pkgname.initd" "$pkgdir/etc/init.d/$_pkgname"
- install -Dm755 "$srcdir/$_pkgname.confd" "$pkgdir/etc/conf.d/$_pkgname"
-
-}
-
-md5sums="8f8eae9762ea423957420998f6df1e44 greenbone-security-assistant-6.0.10.tar.gz
-8102119cb9d33f6860b879b976001e73 gsad.initd
-b7ebc9e1b657f3d5fac432842030192c gsad.confd
-acbc1dc7c674d55675ec931a34c10790 gsad.logrotate
-cc7b793ba26393891a079fe990a0c305 001-fortify-source.patch
-bd17aa7ac9a70e97776480c49a263604 002-sys_siglist.patch"
-sha256sums="9581ba04010987ff6f66edc7393595a2e2b05b64d3463886fba9e5d1152cc8df greenbone-security-assistant-6.0.10.tar.gz
-033244a85159be21cd0a5037613115e8d45b503b885eabfdffa294249caade1e gsad.initd
-e5441e7870f7e83f0c4a37721bc0f505de6dd69786baadeb14901b3ae88e1058 gsad.confd
-520799df540fc9d665d03095c368d3f7b61badd28fc9e4d1dbd095e374e7eff2 gsad.logrotate
-40b340828d4711bffc579a3c3709bafee5983d1501bcd387f41b7e9350dabeda 001-fortify-source.patch
-8573e2c4effc3ecf21a90380b46fd1851e364b4007bee7cf7eace19ac2ffe727 002-sys_siglist.patch"
-sha512sums="0b0e58cef21440764bf2b756f5ab34fb690aedb9d632ec731fe51e3c311e4d0152383487b458662fd28430d1da6ba7dec78b1ec4aaafdfa41dfd8d21e55b21c7 greenbone-security-assistant-6.0.10.tar.gz
-d4bd227aeb31393bc147cb638515871bb7a8096a8ebc9bfb9e15f7d41e8c0e289042c2490ee46ca69b039d31d4c7b401523c7496732ee695af8743a75eb83ba5 gsad.initd
-60758afbeaf7b0938bee3f9f16d444bb0265a274dd85f2acf878583648b5a4cc2ebc5430fd21a04b3e37d242055466a7b2b2636361bbbd6acb8197c4bf83111c gsad.confd
-0d459084f95e00dfb06912b9d89af011fac117a32687ffd3da3887c24e80c074b681c0d87532a4a7511e42c540f8d8b2ceaa04208fff531b94047a08decddd0f gsad.logrotate
-7f43460d0a71a29b79345c64342186dcfbdc5345703d35a1493f39df76ac5e4c1b998e1d8d8915ceca31e29d936218c20597412afb93b434cd35f16f666e1cd0 001-fortify-source.patch
-51da67628959894b8e9b6de102372f9bad6922379199141706686d4dcdb4ca545e8503510d345a96f16397a782e99574b1ca8c93f5983402c50d9fa9930c1cb5 002-sys_siglist.patch"
diff --git a/community/greenbone-security-assistant/gsad.confd b/community/greenbone-security-assistant/gsad.confd
deleted file mode 100644
index 96e77367b1..0000000000
--- a/community/greenbone-security-assistant/gsad.confd
+++ /dev/null
@@ -1,8 +0,0 @@
-# If you want ssl, you need a certificate
-GSAD_EXTRA_ARGS="--http-only"
-#By default on locallhost, but you might want to use a reachable ip address
-GSAD_LISTEN="--listen=127.0.0.1"
-#Manager listens on given address - by default manager listens on all addresses
-MANAGER_LISTEN="--mlisten=127.0.0.1"
-#Manager listens on given port - by default 9390
-MANAGER_PORT="--mport=9390"
diff --git a/community/greenbone-security-assistant/gsad.initd b/community/greenbone-security-assistant/gsad.initd
deleted file mode 100644
index 9655c7bf7f..0000000000
--- a/community/greenbone-security-assistant/gsad.initd
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/sbin/openrc-run
-#Copyright 2016 Alpine Linux
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-command_args="${GSAD_LISTEN} ${MANAGER_LISTEN} ${MANAGER_PORT} ${GSAD_EXTRA_ARGS}"
-name="Greenbone Security Assistant (GSA)"
-command=/usr/bin/gsad
-
-pidfile="/run/gsad.pid"
-
-depend() {
- after bootmisc
- need net
-}
-
diff --git a/community/greenbone-security-assistant/gsad.logrotate b/community/greenbone-security-assistant/gsad.logrotate
deleted file mode 100644
index f0948cbea1..0000000000
--- a/community/greenbone-security-assistant/gsad.logrotate
+++ /dev/null
@@ -1,11 +0,0 @@
-# logrotate for openvas
-/var/log/openvas/gsad.log {
- rotate 4
- weekly
- compress
- delaycompress
- missingok
- postrotate
- /bin/kill -HUP `pidof gsad`
- endscript
-}