aboutsummaryrefslogtreecommitdiffstats
path: root/community/greenbone-security-assistant
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-05-29 13:48:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-29 13:48:58 +0000
commitb3afbaf3034623892824e9afdcdbabe17ff60f6b (patch)
treebe555436006da11a2cdf5eeec525a0b61a0a0a96 /community/greenbone-security-assistant
parentf6f81ef37ee42f7aef3df5cbfa882d86d26000a6 (diff)
downloadaports-b3afbaf3034623892824e9afdcdbabe17ff60f6b.tar.bz2
aports-b3afbaf3034623892824e9afdcdbabe17ff60f6b.tar.xz
community/greenbone-security-assistant: remove husky due to his automatic git-hook install
Diffstat (limited to 'community/greenbone-security-assistant')
-rw-r--r--community/greenbone-security-assistant/APKBUILD11
-rw-r--r--community/greenbone-security-assistant/remove-husky-git-hook.patch30
2 files changed, 35 insertions, 6 deletions
diff --git a/community/greenbone-security-assistant/APKBUILD b/community/greenbone-security-assistant/APKBUILD
index b154db732c..44761d80af 100644
--- a/community/greenbone-security-assistant/APKBUILD
+++ b/community/greenbone-security-assistant/APKBUILD
@@ -3,7 +3,7 @@
pkgname=greenbone-security-assistant
_pkgname=gsad
pkgver=8.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Greenbone Security Assistant (gsa) - OpenVAS web frontend"
url="http://www.openvas.org/"
arch="all"
@@ -20,11 +20,11 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/gsa/archive/v${pkg
$_pkgname.logrotate
cmakelist.patch
sys-siglist.patch
- musl-stack-size.patch"
+ musl-stack-size.patch
+ remove-husky-git-hook.patch"
builddir="$srcdir/gsa-$pkgver"
build() {
- cd "$builddir"
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DSYSCONFDIR=/etc \
@@ -34,12 +34,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 "$srcdir/$_pkgname.logrotate" "$pkgdir/etc/logrotate.d/$_pkgname"
install -Dm755 "$srcdir/$_pkgname.initd" "$pkgdir/etc/init.d/$_pkgname"
@@ -52,4 +50,5 @@ aea96cef16ca7a63570c2d94a1fc7ef27d4163c28e1d729fd11821295f88a96864add0146d407e7b
0d459084f95e00dfb06912b9d89af011fac117a32687ffd3da3887c24e80c074b681c0d87532a4a7511e42c540f8d8b2ceaa04208fff531b94047a08decddd0f gsad.logrotate
6752bb6834811fc7c1259d2c8a0ae5f25a01de881008f6f6635b1f7a43672b5c1862de5b3591f81d7a2f22258614b71bb6ab588a3930648d9d74ef8a75d28c92 cmakelist.patch
1fd6585bc5c5131d19d5d89ddc56b683d5ab1b28793059f5b147ad05eb6330b69d590caa2f12afce6da20b1676d8cdd26d90e51d165e94b308643ec7d2525015 sys-siglist.patch
-5083162dd8f324e102731f691f575adb791861d13d857e37bf0e2aa39b875facae8e7b1ad37a0d60860495603df90ef785cab13685c4405d14e06aca1d8bfe5e musl-stack-size.patch"
+5083162dd8f324e102731f691f575adb791861d13d857e37bf0e2aa39b875facae8e7b1ad37a0d60860495603df90ef785cab13685c4405d14e06aca1d8bfe5e musl-stack-size.patch
+61a2ad4f6f5742de36e1468f5c4f6d85099e9b8c6be805eb08aea05ffed183d1d972063596193e5e2305d4c133392a698123e364e1e0fe5c90889b50f235172a remove-husky-git-hook.patch"
diff --git a/community/greenbone-security-assistant/remove-husky-git-hook.patch b/community/greenbone-security-assistant/remove-husky-git-hook.patch
new file mode 100644
index 0000000000..9c628920a7
--- /dev/null
+++ b/community/greenbone-security-assistant/remove-husky-git-hook.patch
@@ -0,0 +1,30 @@
+diff --git a/gsa/package.json b/gsa/package.json
+index bfed2dc..174462c 100644
+--- a/gsa/package.json
++++ b/gsa/package.json
+@@ -75,7 +75,6 @@
+ },
+ "devDependencies": {
+ "eslint-config-prettier": "^4.0.0",
+- "husky": "^1.3.1",
+ "jest-dom": "^3.0.0",
+ "jest-junit": "^6.0.1",
+ "jest-styled-components": "^6.2.0",
+@@ -97,16 +96,5 @@
+ "not dead",
+ "not ie < 11",
+ "not op_mini all"
+- ],
+- "husky": {
+- "hooks": {
+- "pre-commit": "lint-staged"
+- }
+- },
+- "lint-staged": {
+- "*.{js,json}": [
+- "prettier --write",
+- "git add"
+- ]
+- }
++ ]
+ }