aboutsummaryrefslogtreecommitdiffstats
path: root/community/gsoap
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-07 17:15:45 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-07 17:15:45 +0000
commitabcb8687bdabc3db02544ce80103fba0e0a33267 (patch)
tree4fbde70b7640fea609cc8c0bde91e513cd0613f7 /community/gsoap
parent9e3ca8b0d60b0f6e6c1837eca655e10cab5f8dfd (diff)
downloadaports-abcb8687bdabc3db02544ce80103fba0e0a33267.tar.bz2
aports-abcb8687bdabc3db02544ce80103fba0e0a33267.tar.xz
community/gsoap: upgrade to 2.8.55 and modernize
Diffstat (limited to 'community/gsoap')
-rw-r--r--community/gsoap/APKBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/community/gsoap/APKBUILD b/community/gsoap/APKBUILD
index 0267f1993a..f925c815bc 100644
--- a/community/gsoap/APKBUILD
+++ b/community/gsoap/APKBUILD
@@ -1,13 +1,12 @@
# Contributor: <xmingske@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=gsoap
-pkgver=2.8.54
-pkgrel=1
+pkgver=2.8.55
+pkgrel=0
arch="all"
pkgdesc='A cross-platform C and C++ SDK for SOAP/XML Web services'
license="GPL-2 gSOAP"
url="http://gsoap2.sourceforge.net"
-depends=
makedepends="autoconf automake bison flex zlib-dev libressl-dev libtool"
subpackages="$pkgname-dev"
source="http://downloads.sourceforge.net/project/gsoap2/gsoap-${pkgver%.*}/gsoap_$pkgver.zip
@@ -15,25 +14,24 @@ source="http://downloads.sourceforge.net/project/gsoap2/gsoap-${pkgver%.*}/gsoap
libressl.patch
"
-builddir="$srcdir"/$pkgname-${pkgver%.*}
+builddir="$srcdir/$pkgname-${pkgver%.*}"
build() {
- cd "${builddir}"
+ cd "$builddir"
touch configure.ac aclocal.m4 configure Makefile.am Makefile.in
./configure --prefix=/usr \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--exec-prefix=/usr \
- --enable-ipv6 \
- || return 1
- make -j1 || return 1
+ --enable-ipv6
+ make -j1
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
-sha512sums="59e59dbcb0c7b6f13771c0cd26412941da0a15e05c539dcfaa7deecd83e15b50656454daf6c80eefb85e2d8830748a4fd48970e6de68fd1e2b96ce9a7c0d1874 gsoap_2.8.54.zip
+sha512sums="e0cb6809d5b8e4a068ed937f253844f88d8275e58f7590ca0dd52bede1ea74d5781d35664586f9e29f2e22c508167df8044d45101f0773c9b8d79b80aa188935 gsoap_2.8.55.zip
ab917ece2b7fc507138c7920ddce99ef7a482bfef9e323366940987a75e7594ca91a081ed8d9b6a6b050346a6ebe7c9a9d2de9483beb54768384177e4bc15b9b musl-fixes.patch
a0892700b55562880a58cd8411fb3386a2ae1785c9212a59d0d1c8ccdfa86553bb8d6fb3dd6c923453a1a47c586edbc924c6e7bd4f2436948693e39bd3b1ec73 libressl.patch"