aboutsummaryrefslogtreecommitdiffstats
path: root/community/gspell
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-09-22 23:51:29 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-09-22 23:52:42 +0200
commitfa439b3dcc6f2518f09bedb9645ef690094f941f (patch)
tree7226bc7c7d2d2781198ce2dcd3bfa6d7814d20c4 /community/gspell
parentea6ef25b39d3542fe85fa7a6fca781f0bd00c7bd (diff)
downloadaports-fa439b3dcc6f2518f09bedb9645ef690094f941f.tar.bz2
aports-fa439b3dcc6f2518f09bedb9645ef690094f941f.tar.xz
community/gspell: move from testing
Diffstat (limited to 'community/gspell')
-rw-r--r--community/gspell/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/gspell/APKBUILD b/community/gspell/APKBUILD
new file mode 100644
index 0000000000..463d32180b
--- /dev/null
+++ b/community/gspell/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=gspell
+pkgver=1.8.2
+pkgrel=0
+pkgdesc="Flexible API to add spell checking to a GTK+ application"
+url="https://wiki.gnome.org/Projects/gspell"
+arch="all"
+license="LGPL-2.1-or-later"
+depends="iso-codes"
+makedepends="glib-dev vala iso-codes-dev gtk+3.0-dev enchant2-dev
+ gobject-introspection-dev"
+checkdepends="xvfb-run hunspell-en ibus"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/gspell/${pkgver%.*}/gspell-$pkgver.tar.xz"
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ xvfb-run make check
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="220bdec2b8229e848960e5e31bda1209dedac232637d3e6d4931ca2552054fbdf3f576d52f3d5a7ac734e6e626f2fcc7cefd0bff906b29ba9930cef791906c32 gspell-1.8.2.tar.xz"