aboutsummaryrefslogtreecommitdiffstats
path: root/community/gtk-engines
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-25 06:37:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 06:37:19 -0300
commit5fb7956a67b3d1760f3601e1d88ce54e16ecdbe4 (patch)
tree408ad227ae8e1d5830c56efe31dfc169adcc6c35 /community/gtk-engines
parent91eb57d26852a9ebad66c78d1cb2358c4675b4ee (diff)
downloadaports-5fb7956a67b3d1760f3601e1d88ce54e16ecdbe4.tar.bz2
aports-5fb7956a67b3d1760f3601e1d88ce54e16ecdbe4.tar.xz
community/gtk-engines: move from main
Diffstat (limited to 'community/gtk-engines')
-rw-r--r--community/gtk-engines/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/community/gtk-engines/APKBUILD b/community/gtk-engines/APKBUILD
new file mode 100644
index 0000000000..a39a988100
--- /dev/null
+++ b/community/gtk-engines/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor:
+# Maintainer:
+pkgname=gtk-engines
+pkgver=2.21.0
+pkgrel=3
+pkgdesc="collection of gtk+ engines"
+url="https://www.gtk.org/"
+arch="all"
+license="LGPL-2.1-or-later"
+depends="$pkgname-clearlooks
+ $pkgname-crux
+ $pkgname-industrial
+ $pkgname-mist
+ $pkgname-redmond
+ $pkgname-thinice
+ "
+makedepends="gtk+-dev intltool"
+subpackages="$pkgname-lang $pkgname-dev $depends"
+source="https://dev.alpinelinux.org/archive/gtk-engines/gtk-engines-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-animation \
+ --disable-scrollkeeper
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+_mv_engine() {
+ pkgdesc="GTK $1 engine"
+ replaces="gtk-engines"
+ depends=
+ cd "$pkgdir"
+ find -name "$2" | while read i; do
+ mkdir -p "$subpkgdir"/${i%/*}
+ mv $i "$subpkgdir"/$i
+ done
+}
+
+clearlooks() { _mv_engine "Clearlooks" '*[Cc]learlooks*'; }
+crux() { _mv_engine "Crux" '*[Cc]rux*'; }
+industrial() { _mv_engine "Industrial" '*[Ii]ndustrial*'; }
+mist() { _mv_engine "Mist" '*[Mm]ist*'; }
+redmond() { _mv_engine "Redmond" '*[Rr]edmond*'; }
+thinice() { _mv_engine "ThinIce" '*[Tt]hin[Ii]ce*'; }
+
+sha512sums="2dbd9d57ba09dca7a343d966f15b00c97ff564d9c284b743a0a661a3fba596ed8ec90dd4e155dd1672cca2e9e478034c384fd13a98b1fe0656e0635cc530040b gtk-engines-2.21.0.tar.gz"