aboutsummaryrefslogtreecommitdiffstats
path: root/community/gvm-tools
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-12-05 17:08:58 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-12-05 17:08:58 +0000
commit77aaf9f34052e05fad652fde27d44c048abb986a (patch)
treef04876d677abdb9ed5382c93c6a72b91501f6038 /community/gvm-tools
parent21fee56fb5eac09fdf004705e8c87b9a21445360 (diff)
downloadaports-77aaf9f34052e05fad652fde27d44c048abb986a.tar.bz2
aports-77aaf9f34052e05fad652fde27d44c048abb986a.tar.xz
community/gvm-tools: moved from testing. Added missing dependencies
Diffstat (limited to 'community/gvm-tools')
-rw-r--r--community/gvm-tools/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/gvm-tools/APKBUILD b/community/gvm-tools/APKBUILD
new file mode 100644
index 0000000000..0608f2d442
--- /dev/null
+++ b/community/gvm-tools/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=gvm-tools
+pkgver=1.2.0
+pkgrel=3
+_commitid=77352f8dfa2e
+pkgdesc="Collection of tools for remote controlling a OpenVAS / Greenbone"
+url="https://github.com/greenbone/gvm-tools"
+arch="noarch"
+license="GPL"
+depends="python3 py3-dialog py3-paramiko py3-lxml"
+makedepends="python3-dev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/greenbone/gvm-tools/archive/$pkgver.tar.gz"
+builddir="$srcdir/greenbone-$pkgname-$_commitid"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3e73c72827790e8a99ea26f06c84cdad34e779acd07d12fa56e8a58cb82dbba5f531af1c3e224fe3f2910bfadd276aeeec7fc6a274b6122de377573127f3acca gvm-tools-1.2.0.tar.gz"