aboutsummaryrefslogtreecommitdiffstats
path: root/community/gvmd
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-02-22 00:24:16 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2020-02-22 00:24:44 +0100
commitfded05e6427c299fc62de22f7526bdd9647f92b7 (patch)
tree1b71ddd1a29313786c44dde3743654112949fbe0 /community/gvmd
parentd241a2c607d162a18ff2d522220a37121a1460db (diff)
downloadaports-fded05e6427c299fc62de22f7526bdd9647f92b7.tar.bz2
aports-fded05e6427c299fc62de22f7526bdd9647f92b7.tar.xz
community/gvmd: fix build with CMake None build type
Without introducing a new dependency by passing -DNDEBUG.
Diffstat (limited to 'community/gvmd')
-rw-r--r--community/gvmd/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/community/gvmd/APKBUILD b/community/gvmd/APKBUILD
index 70f751bc39..4e882ed23c 100644
--- a/community/gvmd/APKBUILD
+++ b/community/gvmd/APKBUILD
@@ -39,7 +39,9 @@ prepare() {
build() {
cd "$builddir"/build
- cmake -DCMAKE_BUILD_TYPE=None \
+ # Requires libexecinfo when compiled without -DNDEBUG.
+ CFLAGS="$CFLAGS -DNDEBUG" \
+ cmake -DCMAKE_BUILD_TYPE=None \
-DSBINDIR=/usr/bin \
-DCMAKE_INSTALL_PREFIX=/usr \
-DSYSCONFDIR=/etc \