aboutsummaryrefslogtreecommitdiffstats
path: root/community/hivex
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 20:17:45 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 21:20:49 -0300
commit21f440daa5c0077806cbb2e99daadd159294de30 (patch)
tree44c1181eca375a5cdd520ffa54518866f668222f /community/hivex
parent620178229e6e78741a63c96f495a48247f44e488 (diff)
downloadaports-21f440daa5c0077806cbb2e99daadd159294de30.tar.bz2
aports-21f440daa5c0077806cbb2e99daadd159294de30.tar.xz
community/hivex: drop python2 bindings
Diffstat (limited to 'community/hivex')
-rw-r--r--community/hivex/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/hivex/APKBUILD b/community/hivex/APKBUILD
index d58c55e8d9..6fe5cf2cae 100644
--- a/community/hivex/APKBUILD
+++ b/community/hivex/APKBUILD
@@ -2,19 +2,17 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=hivex
pkgver=1.3.18
-pkgrel=2
+pkgrel=3
pkgdesc="System for extracting the contents of Windows Registry."
url="http://libguestfs.org"
arch="all"
license="LGPL-2.1"
-makedepends="python2-dev libxml2-dev readline-dev perl-dev"
+makedepends="libxml2-dev readline-dev perl-dev"
checkdepends="bash"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://libguestfs.org/download/$pkgname/$pkgname-$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="http://libguestfs.org/download/hivex/hivex-$pkgver.tar.gz"
build() {
- cd "$builddir"
./configure \
--bindir=/usr/bin \
--libdir=/usr/lib \
@@ -23,17 +21,16 @@ build() {
--disable-perl \
--disable-ruby \
--disable-ocaml \
+ --disable-python \
--disable-static
make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}